summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeon Spengler2021-09-02 22:31:42 +0200
committerDeon Spengler2021-09-02 22:31:42 +0200
commit8abe2bf347eb3422bde1f685f1783d796594652e (patch)
tree3ab414c9881285e1ba7fdcce5eaee35b1fecd778
parent45f883ceaab858df2592e5ee5519e43a4bb91e17 (diff)
downloadaur-8abe2bf347eb3422bde1f685f1783d796594652e.tar.gz
Update to SOGo-5.2.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
-rw-r--r--sogo_configure.patch14
3 files changed, 12 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 350f6d1907af..2b9dc06abfb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sogo
pkgdesc = groupware server built around OpenGroupware.org (OGo) and the SOPE application server
- pkgver = 5.1.0
+ pkgver = 5.2.0
pkgrel = 1
url = http://www.sogo.nu/
install = sogo.install
@@ -8,7 +8,7 @@ pkgbase = sogo
license = GPL
makedepends = gcc-objc
makedepends = gnustep-make
- depends = sope>=5.1.0
+ depends = sope>=5.2.0
depends = gnustep-base
depends = libmemcached
depends = memcached
@@ -16,6 +16,7 @@ pkgbase = sogo
depends = mariadb-libs
depends = inetutils
depends = libsodium
+ depends = libytnef
depends = libzip
optdepends = postgresql: run database server for sogo locally
optdepends = mariadb: run database server for sogo locally
@@ -31,14 +32,11 @@ pkgbase = sogo
backup = etc/sogo/sogo.conf
backup = etc/httpd/conf/extra/SOGo.conf
backup = etc/conf.d/sogo
- source = http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-5.1.0.tar.gz
+ source = http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-5.2.0.tar.gz
source = sogo.service
source = sogo.confd
- source = sogo_configure.patch
- sha256sums = dd4780be9aaa4c197e4c489c7a13280401c11fc4483b0a5da505cb6c8f1f5ca3
+ sha256sums = 6f738f7f55ec24eba838cd2fee8f3b136d67cd56afd660113c863daa0fb2333a
sha256sums = 0720b9ad35a05d86d794c7adbf18277ecde57ed147e96f6105acca93f19d3b8c
sha256sums = 8ee0d1ad77e998ea801053fce175d8c4a1c55dcc5ee1ff78f0a8e3797187a6a7
- sha256sums = e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1
pkgname = sogo
-
diff --git a/PKGBUILD b/PKGBUILD
index 311e135e033c..9ec55a7d0889 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Andre Wayand <aur-sogo@awayand.sleepmail.com>
pkgname=sogo
pkgdesc="groupware server built around OpenGroupware.org (OGo) and the SOPE application server"
-pkgver=5.1.0
+pkgver=5.2.0
pkgrel=1
arch=('x86_64')
url="http://www.sogo.nu/"
@@ -22,6 +22,7 @@ depends=("sope>=${pkgver}"
'mariadb-libs'
'inetutils'
'libsodium'
+ 'libytnef'
'libzip')
optdepends=('postgresql: run database server for sogo locally'
'mariadb: run database server for sogo locally'
@@ -37,27 +38,19 @@ backup=('etc/sogo/sogo.conf'
'etc/conf.d/sogo')
source=("http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-${pkgver}.tar.gz"
"sogo.service"
- "sogo.confd"
- "sogo_configure.patch")
-sha256sums=('dd4780be9aaa4c197e4c489c7a13280401c11fc4483b0a5da505cb6c8f1f5ca3'
+ "sogo.confd")
+sha256sums=('6f738f7f55ec24eba838cd2fee8f3b136d67cd56afd660113c863daa0fb2333a'
'0720b9ad35a05d86d794c7adbf18277ecde57ed147e96f6105acca93f19d3b8c'
- '8ee0d1ad77e998ea801053fce175d8c4a1c55dcc5ee1ff78f0a8e3797187a6a7'
- 'e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1')
-
-prepare() {
- cd "$srcdir/SOGo-${pkgver}"
-
- patch configure ../sogo_configure.patch
-}
+ '8ee0d1ad77e998ea801053fce175d8c4a1c55dcc5ee1ff78f0a8e3797187a6a7')
build() {
- cd "$srcdir/SOGo-${pkgver}"
+ cd "SOGo-${pkgver}"
./configure --prefix=$(gnustep-config --variable=GNUSTEP_SYSTEM_ROOT) --disable-debug
make
}
package() {
- cd "${srcdir}/SOGo-${pkgver}"
+ cd "SOGo-${pkgver}"
make install DESTDIR="${pkgdir}"
install -D -m 0644 "${srcdir}"/sogo.service \
"${pkgdir}"/usr/lib/systemd/system/sogo.service
diff --git a/sogo_configure.patch b/sogo_configure.patch
deleted file mode 100644
index 6bf5414db30d..000000000000
--- a/sogo_configure.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-251,261c251
-< UNAME=`uname`
-< if [ "X${UNAME}" = "XLinux" ];then
-< UNAME=`uname -m`
-< if [ ${UNAME} = x86_64 -o ${UNAME} = sparc64 -o ${UNAME} = ppc64 ];then
-< cfgwrite "CGS_LIBDIR_NAME:=lib64"
-< else
-< cfgwrite "CGS_LIBDIR_NAME:=lib"
-< fi
-< else
-< cfgwrite "CGS_LIBDIR_NAME:=lib"
-< fi
----
-> cfgwrite "CGS_LIBDIR_NAME:=lib"