summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeon Spengler2020-10-22 18:05:22 +0200
committerDeon Spengler2020-10-22 18:05:22 +0200
commit8b846bcace8600fcb413393c2445c86ac6af8786 (patch)
tree22e74346f72830ce2e1bf0d42e788235be34a431
parentbb4305f957515d34e1c870e64f3d3f6ce8026f93 (diff)
downloadaur-8b846bcace8600fcb413393c2445c86ac6af8786.tar.gz
Update to SOGo-5.0.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
-rw-r--r--gcc10-fix.patch13
3 files changed, 17 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa565d743ec7..9bbe33efb6a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sogo
pkgdesc = groupware server built around OpenGroupware.org (OGo) and the SOPE application server
- pkgver = 5.0.0
+ pkgver = 5.0.1
pkgrel = 1
url = http://www.sogo.nu/
install = sogo.install
@@ -8,11 +8,15 @@ pkgbase = sogo
license = GPL
makedepends = gcc-objc
makedepends = gnustep-make
- depends = sope>=5.0.0
+ depends = sope>=5.0.1
depends = gnustep-base
depends = libmemcached
depends = memcached
depends = libwbxml
+ depends = mariadb-libs
+ depends = inetutils
+ depends = libsodium
+ depends = libzip
optdepends = postgresql: run database server for sogo locally
optdepends = mariadb: run database server for sogo locally
optdepends = openldap: run directory server for sogo locally
@@ -27,16 +31,14 @@ pkgbase = sogo
backup = etc/sogo/sogo.conf
backup = etc/httpd/conf/extra/SOGo.conf
backup = etc/conf.d/sogo
- source = http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-5.0.0.tar.gz
+ source = http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-5.0.1.tar.gz
source = sogo.service
source = sogo.confd
source = sogo_configure.patch
- source = gcc10-fix.patch
- sha256sums = 9002554017ac1324672f7e8de5fc68dea0b7d27640b0e54e1c5b9a88cfddff7d
+ sha256sums = e2af4b0b1642dc6094043360bb4b3f3a653d63029139d5c41ed0585ac1b944ed
sha256sums = 0720b9ad35a05d86d794c7adbf18277ecde57ed147e96f6105acca93f19d3b8c
sha256sums = 8ee0d1ad77e998ea801053fce175d8c4a1c55dcc5ee1ff78f0a8e3797187a6a7
sha256sums = e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1
- sha256sums = 3ed561519ad2a635869dd1d961329b557e1fa8fff0b0c4bc7e0b40926a35b13a
pkgname = sogo
diff --git a/PKGBUILD b/PKGBUILD
index 42fe6b807fc3..eb41cdb6e4a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Andre Wayand <aur-sogo@awayand.sleepmail.com>
pkgname=sogo
pkgdesc="groupware server built around OpenGroupware.org (OGo) and the SOPE application server"
-pkgver=5.0.0
+pkgver=5.0.1
pkgrel=1
arch=('x86_64')
url="http://www.sogo.nu/"
@@ -18,7 +18,11 @@ depends=("sope>=${pkgver}"
'gnustep-base'
'libmemcached'
'memcached'
- 'libwbxml')
+ 'libwbxml'
+ 'mariadb-libs'
+ 'inetutils'
+ 'libsodium'
+ 'libzip')
optdepends=('postgresql: run database server for sogo locally'
'mariadb: run database server for sogo locally'
'openldap: run directory server for sogo locally'
@@ -34,19 +38,16 @@ backup=('etc/sogo/sogo.conf'
source=("http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-${pkgver}.tar.gz"
"sogo.service"
"sogo.confd"
- "sogo_configure.patch"
- "gcc10-fix.patch")
-sha256sums=('9002554017ac1324672f7e8de5fc68dea0b7d27640b0e54e1c5b9a88cfddff7d'
+ "sogo_configure.patch")
+sha256sums=('e2af4b0b1642dc6094043360bb4b3f3a653d63029139d5c41ed0585ac1b944ed'
'0720b9ad35a05d86d794c7adbf18277ecde57ed147e96f6105acca93f19d3b8c'
'8ee0d1ad77e998ea801053fce175d8c4a1c55dcc5ee1ff78f0a8e3797187a6a7'
- 'e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1'
- '3ed561519ad2a635869dd1d961329b557e1fa8fff0b0c4bc7e0b40926a35b13a')
+ 'e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1')
prepare() {
cd "$srcdir/SOGo-${pkgver}"
patch configure ../sogo_configure.patch
- patch -Np1 -i ../gcc10-fix.patch
}
build() {
diff --git a/gcc10-fix.patch b/gcc10-fix.patch
deleted file mode 100644
index ec37e375e110..000000000000
--- a/gcc10-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/SoObjects/Mailer/SOGoMailObject.h b/SoObjects/Mailer/SOGoMailObject.h
-index 2d412e47c..5b53c4f54 100644
---- a/SoObjects/Mailer/SOGoMailObject.h
-+++ b/SoObjects/Mailer/SOGoMailObject.h
-@@ -51,7 +51,7 @@
-
- @class WOResponse;
-
--NSArray *SOGoMailCoreInfoKeys;
-+extern NSArray *SOGoMailCoreInfoKeys;
-
- @interface SOGoMailObject : SOGoMailBaseObject
- {