summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeon Spengler2020-06-01 21:48:58 +0200
committerDeon Spengler2020-06-01 21:48:58 +0200
commitcae339df8fec270b6d2c1a34cf14c989c72f90ac (patch)
treeacbd7657f20703204064da43eae942e2266af3cd
parent2a6363ca9045a96ccdd81962797f4bcb1c960864 (diff)
downloadaur-cae339df8fec270b6d2c1a34cf14c989c72f90ac.tar.gz
bugfix 0005029
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--gcc10-fix.patch13
-rw-r--r--patch-gnustep-base-1.27.patch44
4 files changed, 73 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ceb858a1cbb0..46c8dc091907 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sogo
pkgdesc = groupware server built around OpenGroupware.org (OGo) and the SOPE application server
pkgver = 4.3.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.sogo.nu/
install = sogo.install
arch = x86_64
@@ -31,10 +31,14 @@ pkgbase = sogo
source = sogo.service
source = sogo.confd
source = sogo_configure.patch
+ source = gcc10-fix.patch
+ source = patch-gnustep-base-1.27.patch
sha256sums = ecf22e7763a3113ac86a891abbd0e50f7eac19275428798c34cf742cc83a446b
sha256sums = 0720b9ad35a05d86d794c7adbf18277ecde57ed147e96f6105acca93f19d3b8c
sha256sums = 8ee0d1ad77e998ea801053fce175d8c4a1c55dcc5ee1ff78f0a8e3797187a6a7
sha256sums = e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1
+ sha256sums = 3ed561519ad2a635869dd1d961329b557e1fa8fff0b0c4bc7e0b40926a35b13a
+ sha256sums = 663a9887ce7b31d6d6f4a54e7fe2d84dc2a569a5844a3194f8b9d7ee479f7c67
pkgname = sogo
diff --git a/PKGBUILD b/PKGBUILD
index 18280377fc2e..8311d47e4665 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=sogo
pkgdesc="groupware server built around OpenGroupware.org (OGo) and the SOPE application server"
pkgver=4.3.2
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="http://www.sogo.nu/"
license=('GPL')
@@ -13,7 +13,7 @@ options=('!strip')
replaces=('sogo2')
install=sogo.install
makedepends=('gcc-objc'
- 'gnustep-make<=1.26.0')
+ 'gnustep-make')
depends=("sope>=${pkgver}"
'gnustep-base'
'libmemcached'
@@ -34,15 +34,22 @@ backup=('etc/sogo/sogo.conf'
source=("http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-${pkgver}.tar.gz"
"sogo.service"
"sogo.confd"
- "sogo_configure.patch")
+ "sogo_configure.patch"
+ "gcc10-fix.patch"
+ "patch-gnustep-base-1.27.patch")
sha256sums=('ecf22e7763a3113ac86a891abbd0e50f7eac19275428798c34cf742cc83a446b'
'0720b9ad35a05d86d794c7adbf18277ecde57ed147e96f6105acca93f19d3b8c'
'8ee0d1ad77e998ea801053fce175d8c4a1c55dcc5ee1ff78f0a8e3797187a6a7'
- 'e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1')
+ 'e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1'
+ '3ed561519ad2a635869dd1d961329b557e1fa8fff0b0c4bc7e0b40926a35b13a'
+ '663a9887ce7b31d6d6f4a54e7fe2d84dc2a569a5844a3194f8b9d7ee479f7c67')
prepare() {
cd "$srcdir/SOGo-${pkgver}"
+
patch configure ../sogo_configure.patch
+ patch -Np1 -i ../gcc10-fix.patch
+ patch -Np1 -i ../patch-gnustep-base-1.27.patch
}
build() {
diff --git a/gcc10-fix.patch b/gcc10-fix.patch
new file mode 100644
index 000000000000..ec37e375e110
--- /dev/null
+++ b/gcc10-fix.patch
@@ -0,0 +1,13 @@
+diff --git a/SoObjects/Mailer/SOGoMailObject.h b/SoObjects/Mailer/SOGoMailObject.h
+index 2d412e47c..5b53c4f54 100644
+--- a/SoObjects/Mailer/SOGoMailObject.h
++++ b/SoObjects/Mailer/SOGoMailObject.h
+@@ -51,7 +51,7 @@
+
+ @class WOResponse;
+
+-NSArray *SOGoMailCoreInfoKeys;
++extern NSArray *SOGoMailCoreInfoKeys;
+
+ @interface SOGoMailObject : SOGoMailBaseObject
+ {
diff --git a/patch-gnustep-base-1.27.patch b/patch-gnustep-base-1.27.patch
new file mode 100644
index 000000000000..2aca56d5fd12
--- /dev/null
+++ b/patch-gnustep-base-1.27.patch
@@ -0,0 +1,44 @@
+diff --git a/ActiveSync/SOGoActiveSyncDispatcher+Sync.m b/ActiveSync/SOGoActiveSyncDispatcher+Sync.m
+index 6465236ec..b32e45360 100644
+--- a/ActiveSync/SOGoActiveSyncDispatcher+Sync.m
++++ b/ActiveSync/SOGoActiveSyncDispatcher+Sync.m
+@@ -2211,7 +2211,7 @@ FIXME
+
+ // Cache-entry still exists but folder doesn't exists or synchronize flag is not set.
+ // We ignore the folder and wait for foldersync to do the cleanup.
+- if (!(mfCollection && [mfCollection synchronize]))
++ if (!(mfCollection && [(SOGoGCSFolder*)mfCollection synchronize]))
+ {
+ if (debugOn)
+ [self logWithFormat: @"EAS - Folder %@ not found. Ignoring ...", folderName];
+@@ -2245,7 +2245,7 @@ FIXME
+ realCollectionId = [folderName realCollectionIdWithFolderType: &mergedFolderType];
+ mfCollection = [self collectionFromId: realCollectionId type: mergedFolderType];
+
+- if (!(mfCollection && [mfCollection synchronize]))
++ if (!(mfCollection && [(SOGoGCSFolder*)mfCollection synchronize]))
+ {
+ if (debugOn)
+ [self logWithFormat: @"EAS - Folder %@ not found. Reset personal folder to cleanup", folderName];
+diff --git a/ActiveSync/SOGoActiveSyncDispatcher.m b/ActiveSync/SOGoActiveSyncDispatcher.m
+index 907612c47..0f1b98642 100644
+--- a/ActiveSync/SOGoActiveSyncDispatcher.m
++++ b/ActiveSync/SOGoActiveSyncDispatcher.m
+@@ -977,7 +977,7 @@ void handle_eas_terminate(int signum)
+ }
+
+ // Remove the folder from device if it doesn't exist, or don't want to sync it.
+- if (!currentFolder || !([currentFolder synchronize]))
++ if (!currentFolder || !([(SOGoGCSFolder*)currentFolder synchronize]))
+ {
+ // Don't send a delete when MergedFoler is set, we have done it above.
+ // Windows Phones don't like when a <Delete>-folder is sent twice.
+@@ -1135,7 +1135,7 @@ void handle_eas_terminate(int signum)
+ continue;
+
+ if (![currentFolder isKindOfClass: [SOGoGCSFolder class]] ||
+- ![currentFolder synchronize])
++ ![(SOGoGCSFolder*)currentFolder synchronize])
+ {
+ [folders removeObjectAtIndex: count];
+ continue;