summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgameslayer2024-04-01 17:10:38 +1000
committergameslayer2024-04-01 17:10:38 +1000
commit8577d0a10777a300c3b0e7c5f5448a968c25f315 (patch)
tree7b83ee82158e43c845a7e61e99fe0b406b5fb890
downloadaur-8577d0a10777a300c3b0e7c5f5448a968c25f315.tar.gz
soh-bin 8.0.5-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd94069b4919
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = soh-bin
+ pkgdesc = Ship of Sarkinian Reimplimentation engine
+ pkgver = 8.0.5
+ pkgrel = 1
+ url = https://gitlab.com/soh-bin
+ arch = x86_64
+ arch = aarch64
+ license = GPL
+ makedepends = unzip
+ depends = sdl2
+ depends = sdl2_net
+ depends = libpng
+ source_x86_64 = https://gitlab.com/soh-bin/binaries/8.0.5/-/raw/main/soh-linux-x64.tar.xz
+ sha256sums_x86_64 = SKIP
+ source_aarch64 = https://gitlab.com/soh-bin/binaries/8.0.5/-/raw/main/soh-linux-arm64.tar.xz
+ sha256sums_aarch64 = SKIP
+
+pkgname = soh-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e25d44946532
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=soh-bin
+pkgver=8.0.5
+pkgrel=1
+_pkgrel_x86_64=1
+_pkgrel_aarch64=1
+pkgdesc="Ship of Sarkinian Reimplimentation engine"
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/soh-bin"
+license=('GPL')
+depends=('sdl2' 'sdl2_net' 'libpng')
+makedepends=('unzip')
+sha256sums_x86_64=('SKIP')
+sha256sums_aarch64=('SKIP')
+source_x86_64=("https://gitlab.com/soh-bin/binaries/$pkgver/-/raw/main/soh-linux-x64.tar.xz")
+source_aarch64=("https://gitlab.com/soh-bin/binaries/$pkgver/-/raw/main/soh-linux-arm64.tar.xz")
+
+package() {
+ install -dm755 "$pkgdir/usr/bin"
+ mv "$srcdir/soh" "$pkgdir/usr/bin"
+}