summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAltoXorg2022-12-09 21:58:36 +0800
committerAltoXorg2022-12-09 21:58:36 +0800
commit765e281c878ca59ffd5bfe828b5f9149939725e8 (patch)
tree9e1f1f83277a69ba9f72833859aa84472782b795
parent766c60bbf5c4b7a87e0c8bcb8e51332049ae4e68 (diff)
downloadaur-765e281c878ca59ffd5bfe828b5f9149939725e8.tar.gz
OTR pkgs: replace simple versioning scheme with exporter's version
so we can ensure that we won't have to change pkgver everytime something changes in the game's assets, whether it be the xml files or custom official textures. - remove soh dependency, as we aren't needing that
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0e6ee0e5f13..30ee677c0cfa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = soh-otr-gc_mq_d
pkgdesc = OTR game data for SoH (Ocarina of Time Master Quest Debug)
- pkgver = 5
+ pkgver = 5.0.2.r69.g408143ec8
pkgrel = 1
+ epoch = 1
url = https://github.com/HarbourMasters/Shipwright
arch = any
license = unknown
makedepends = soh-otr-exporter
makedepends = python
- depends = soh
provides = soh-otr-mq
conflicts = soh-otr-mq
source = verify_baserom.py
diff --git a/PKGBUILD b/PKGBUILD
index bc7a14aec81f..f286fe009561 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,25 @@
_romname=gc_mq_d
_romdesc="Ocarina of Time Master Quest Debug"
pkgname=soh-otr-${_romname}
-pkgver=5
+pkgver=5.0.2.r69.g408143ec8
pkgrel=1
+epoch=1 # For old versions of SoH, if available
pkgdesc="OTR game data for SoH (${_romdesc})"
arch=("any")
url="https://github.com/HarbourMasters/Shipwright"
license=("unknown")
provides=("soh-otr-mq")
conflicts=("soh-otr-mq")
-depends=("soh")
makedepends=("soh-otr-exporter" "python")
source=("verify_baserom.py")
sha256sums=('bd82ccb54e94505549af7dc07b56dc83b3e63e1c65d525b6fb98ed1b56b8aecf')
SHIP_PREFIX=/opt/soh
+pkgver() {
+ pacman -Qi soh-otr-exporter | grep Version | sed 's/.*: //;s/-.*$//'
+}
+
prepare() {
cd "${srcdir}"