summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAltoXorg2023-10-15 00:22:25 +0800
committerAltoXorg2023-10-15 00:22:25 +0800
commit1a68ca77d78b925d21f57bd017fb19a6121e593f (patch)
tree61005a8ac7194101a4cd5f0a893d3a5c64cb09f7
downloadaur-1a68ca77d78b925d21f57bd017fb19a6121e593f.tar.gz
new OOT MQ PAL OTR pkg (1.0)
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2abde6580e6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = soh-otr-n64_pal_10
+ pkgdesc = OTR game data for SoH (Ocarina of Time Europe PAL Version 1.0)
+ pkgver = 7.1.1.r97.g5ddc41877
+ pkgrel = 1
+ epoch = 1
+ url = https://shipofharkinian.com/
+ arch = any
+ license = unknown
+ makedepends = soh-otr-exporter
+ provides = soh-otr
+ conflicts = soh-otr
+ source = file://baserom.z64
+ sha256sums = f29d21e10f77c44d933f07ff6d0f593d4267925f1e6834ce55e239b6037549e7
+
+pkgname = soh-otr-n64_pal_10
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3502d61a54d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: AltoXorg <atrl101 AT yahoo DOT com>
+
+vername=N64_PAL_10
+verdesc="Ocarina of Time Europe PAL Version 1.0"
+pkgname=soh-otr-${vername,,}
+pkgver=7.1.1.r12.g8872a5928
+pkgrel=1
+epoch=1 # For old versions of SoH, if available
+pkgdesc="OTR game data for SoH (${verdesc})"
+arch=("any")
+url="https://shipofharkinian.com/"
+license=("unknown")
+provides=("soh-otr")
+conflicts=("soh-otr")
+makedepends=("soh-otr-exporter")
+source=("file://baserom.z64")
+sha256sums=('f29d21e10f77c44d933f07ff6d0f593d4267925f1e6834ce55e239b6037549e7')
+
+SHIP_PREFIX=/opt/soh
+
+pkgver() {
+ pacman -Q soh-otr-exporter | sed -E 's/.* (.*)-.*$/\1/'
+}
+
+build() {
+ cd "${srcdir}"
+
+ [ -e oot.otr ] && rm oot.otr
+
+ "${SHIP_PREFIX}/assets/extractor/ZAPD.out" ed -eh \
+ -i "${SHIP_PREFIX}/assets/extractor/xmls/${vername}" -b baserom.z64 \
+ -fl "${SHIP_PREFIX}/assets/extractor/filelists" -o . -osf . -gsf 0 \
+ -rconf "${SHIP_PREFIX}/assets/extractor/Config_${vername}.xml" -se OTR --otrfile oot.otr
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm644 oot.otr -t "${pkgdir}/${SHIP_PREFIX}"
+}
+