summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Lansdowne2013-12-22 16:59:03 +0000
committerJoseph Lansdowne2013-12-22 16:59:03 +0000
commit760baa77013a380c1eba1df207206eefccc5296b (patch)
tree83da53fbdf959b0998196e2c5cc5b3d5c9c2c51b
downloadaur-760baa77013a380c1eba1df207206eefccc5296b.tar.gz
add Sokobond package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
-rwxr-xr-xsokobond-bin3
-rw-r--r--sokobond.desktop8
-rw-r--r--sokobond.pngbin0 -> 6772 bytes
5 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86be24056312
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = sokobond
+ pkgdesc = A minimalist puzzle game about bonding chemical elements
+ pkgver = 20130411
+ pkgrel = 1
+ url = http://www.sokobond.com
+ arch = any
+ license = custom:commercial
+ depends = adobe-air
+ source = sokobond-bin
+ source = sokobond.desktop
+ source = sokobond.png
+ md5sums = f3edf9b80f109d83c7240ae01153de50
+ md5sums = f18ec1d1d3e2d8c51ef71f689153f8a3
+ md5sums = 58ee2375b470f7811ab26632b9f3d0ee
+
+pkgname = sokobond
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2aeacecc7d63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Joseph Lansdowne <J49137@gmail.com>
+pkgname=sokobond
+pkgver=20130411
+pkgrel=1
+pkgdesc="A minimalist puzzle game about bonding chemical elements"
+arch=(any)
+url="http://www.sokobond.com"
+license=(custom:commercial)
+depends=(adobe-air)
+source=("$pkgname-bin"
+ "$pkgname.desktop"
+ "$pkgname.png")
+md5sums=('f3edf9b80f109d83c7240ae01153de50'
+ 'f18ec1d1d3e2d8c51ef71f689153f8a3'
+ '58ee2375b470f7811ab26632b9f3d0ee')
+PKGEXT=.pkg.tar
+
+_archive="${pkgname}_linux_11042013.tar.gz"
+_archive_md5='8f554f5d4e262de3ec1d84e2c250cc61'
+
+build () {
+ echo "$_archive_md5 $startdir/$_archive" | md5sum -c || {
+ echo "archive not found or wrong checksum (Sokobond is a commercial" \
+ "game)" 1>&2
+ exit 1
+ }
+
+ bsdtar -xf "$startdir/$_archive" -C "$srcdir"
+}
+
+package () {
+ install -Dm644 "$srcdir/$pkgname/$pkgname.air" \
+ "$pkgdir/opt/$pkgname/$pkgname.air"
+ install -Dm755 "$srcdir/$pkgname-bin" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$srcdir/$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/$pkgname.png" \
+ "$pkgdir/usr/share/pixmaps/$pkgname.png"
+}
diff --git a/sokobond-bin b/sokobond-bin
new file mode 100755
index 000000000000..9f9528e5d154
--- /dev/null
+++ b/sokobond-bin
@@ -0,0 +1,3 @@
+#! /bin/sh
+
+exec adobe-air /opt/sokobond/sokobond.air
diff --git a/sokobond.desktop b/sokobond.desktop
new file mode 100644
index 000000000000..f74cf451ad39
--- /dev/null
+++ b/sokobond.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Sokobond
+Comment=A minimalist puzzle game about bonding chemical elements
+Icon=sokobond
+Exec=/usr/bin/sokobond
+Categories=Game;
diff --git a/sokobond.png b/sokobond.png
new file mode 100644
index 000000000000..40b51eccc53c
--- /dev/null
+++ b/sokobond.png
Binary files differ