summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Ostuni2020-09-30 01:14:36 +0200
committerDario Ostuni2020-09-30 01:14:36 +0200
commit06829eb7ab1c261d559d718966ed5be3bc9da642 (patch)
treec4f9283ea356a4cec6a5a2876beaa8cba66a50ed
downloadaur-06829eb7ab1c261d559d718966ed5be3bc9da642.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7b74da60c61
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = soks-git
+ pkgdesc = A minimalistic SOCKS5 server proxy over a network interface (like a VPN or a second physical network device)
+ pkgver = r4.59552a7
+ pkgrel = 1
+ url = https://github.com/dariost/soks
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = MPL2
+ makedepends = git
+ provides = soks
+ conflicts = soks
+ source = git+https://github.com/dariost/soks.git
+ sha384sums = SKIP
+
+pkgname = soks-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62349d36f93d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Dario Ostuni <dario.ostuni@gmail.com>
+
+pkgname=soks-git
+pkgver=r4.59552a7
+pkgrel=1
+pkgdesc="A minimalistic SOCKS5 server proxy over a network interface (like a VPN or a second physical network device)"
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url="https://github.com/dariost/soks"
+license=('MPL2')
+depends=()
+makedepends=('git')
+provides=('soks')
+conflicts=('soks')
+source=("git+https://github.com/dariost/soks.git")
+sha384sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/soks"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/soks"
+ make
+}
+
+package() {
+ cd "$srcdir/soks"
+ install -Dm755 soks "$pkgdir/usr/bin/soks"
+}