summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-11-05 11:18:24 -0500
committerCarlos Aznarán Laos2021-11-05 11:18:24 -0500
commit590ae5114ac337230db12ba8687b6065a401d83d (patch)
tree79ab6aa342bb62f935a4ba765099bc279cf22364
parenta323710a7c7026975d03c6b859dc8e0113f8f399 (diff)
downloadaur-590ae5114ac337230db12ba8687b6065a401d83d.tar.gz
Version bump to 3.2.3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD39
2 files changed, 25 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index edb7b28b50f7..0bf59f65b8ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = sol2
- pkgdesc = C++ <-> Lua Wrapper Library
- pkgver = 3.2.1
+ pkgdesc = C++ <-> Lua API wrapper with advanced features and top notch performance
+ pkgver = 3.2.3
pkgrel = 1
- url = http://sol2.rtfd.io/
+ url = https://sol2.rtfd.io
arch = any
license = MIT
- makedepends = git
makedepends = python
+ makedepends = git
optdepends = lua
optdepends = lua51
optdepends = lua53
@@ -15,10 +15,9 @@ pkgbase = sol2
provides = sol2
conflicts = sol2
options = !strip
- source = https://github.com/ThePhD/sol2/archive/v3.2.1.tar.gz
- sha256sums = b10f88dc1246f74a10348faef7d2c06e2784693307df74dcd87c4641cf6a6828
+ source = https://github.com/ThePhD/sol2/archive/v3.2.3.tar.gz
+ sha512sums = 448be11555725ddce5ea8d56d793da529c1bb969a4f444ad840044c49a047a5af2abe96d7bf17763246a397eddb4a34e6d299adb14ad3f30f6193f631f27c239
pkgname = sol2
pkgname = sol2-single
-
diff --git a/PKGBUILD b/PKGBUILD
index 653823d8a282..f97bc21eb47a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,32 @@
-# Maintainer: TheAifam5 <theaifam5 at gmail com>
-
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: TheAifam5 <theaifam5 at gmail com>
pkgbase=sol2
pkgname=(sol2 sol2-single)
-pkgver=3.2.1
+pkgver=3.2.3
pkgrel=1
-pkgdesc="C++ <-> Lua Wrapper Library"
+pkgdesc="C++ <-> Lua API wrapper with advanced features and top notch performance"
arch=('any')
options=(!strip)
-url="http://sol2.rtfd.io/"
-license=('MIT')
-makedepends=('git' 'python')
-optdepends=('lua' 'lua51' 'lua53' 'lua52' 'luajit')
-conflicts=('sol2')
-provides=('sol2')
-source=("https://github.com/ThePhD/sol2/archive/v$pkgver.tar.gz")
-sha256sums=('b10f88dc1246f74a10348faef7d2c06e2784693307df74dcd87c4641cf6a6828')
+url="https://sol2.rtfd.io"
+license=(MIT)
+makedepends=(python git)
+optdepends=(lua lua51 lua53 lua52 luajit)
+conflicts=(sol2)
+provides=(sol2)
+source=(https://github.com/ThePhD/${pkgbase}/archive/v${pkgver}.tar.gz)
+sha512sums=('448be11555725ddce5ea8d56d793da529c1bb969a4f444ad840044c49a047a5af2abe96d7bf17763246a397eddb4a34e6d299adb14ad3f30f6193f631f27c239')
package_sol2() {
- cd "./$pkgbase-$pkgver"
+ cd "${pkgbase}-${pkgver}"
- install -d $pkgdir/usr/include/sol
- cp -rf ./include $pkgdir/usr
+ install -d ${pkgdir}/usr/include/sol
+ cp -rf ./include ${pkgdir}/usr
}
package_sol2-single() {
- cd "./$pkgbase-$pkgver/single"
+ cd "${pkgbase}-${pkgver}/single"
- install -d $pkgdir/usr/include/sol
-
- python single.py --input ../include --output $pkgdir/usr/include/sol/sol.hpp
-}
+ install -d ${pkgdir}/usr/include/sol
+ python single.py --input ../include --output ${pkgdir}/usr/include/sol/sol.hpp
+}