summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2022-02-23 09:37:17 -0300
committerRafael Fontenelle2022-02-23 09:37:17 -0300
commit74164610cbd22cbd50400d16bde902352197e48b (patch)
treeb205e2746c30f4ed4bc4d6ec84ce7463be15474b
parent8c28d4e1f390f75fa5de5dd1f7ce592c2b855d92 (diff)
downloadaur-74164610cbd22cbd50400d16bde902352197e48b.tar.gz
Fix ERROR Function does not take positional arguments
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--meson-drop-unused-argument.patch27
3 files changed, 41 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 821aa53e19cb..c018fb3ea307 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = solanum
pkgdesc = A pomodoro timer for the GNOME desktop
pkgver = 3.0.1.r0.g3f84b1d
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.gnome.org/World/solanum
arch = x86_64
license = GPL3
@@ -12,6 +12,8 @@ pkgbase = solanum
depends = libadwaita
depends = gst-plugins-bad-libs
source = git+https://gitlab.gnome.org/World/solanum#commit=3f84b1d0c46fe1a3daef2940b1d0747222023984
- md5sums = SKIP
+ source = meson-drop-unused-argument.patch
+ sha256sums = SKIP
+ sha256sums = e2d30fb22bb8948659d909064df462bd74f44f2eb768757d041618aecb36b245
pkgname = solanum
diff --git a/PKGBUILD b/PKGBUILD
index b59efc287593..26034d976e7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
pkgname=solanum
pkgver=3.0.1.r0.g3f84b1d
-pkgrel=1
+pkgrel=2
pkgdesc="A pomodoro timer for the GNOME desktop"
arch=(x86_64)
url="https://gitlab.gnome.org/World/solanum"
@@ -10,8 +10,15 @@ depends=('libadwaita' 'gst-plugins-bad-libs')
makedepends=('rust' 'meson' 'git')
checkdepends=('appstream-glib')
_commit=3f84b1d0c46fe1a3daef2940b1d0747222023984 # tags/v3.0.1
-source=("git+$url#commit=$_commit")
-md5sums=('SKIP')
+source=("git+$url#commit=$_commit"
+ meson-drop-unused-argument.patch)
+sha256sums=('SKIP'
+ 'e2d30fb22bb8948659d909064df462bd74f44f2eb768757d041618aecb36b245')
+
+prepare() {
+ cd $pkgname
+ git apply "$srcdir/meson-drop-unused-argument.patch"
+}
pkgver() {
cd $pkgname
diff --git a/meson-drop-unused-argument.patch b/meson-drop-unused-argument.patch
new file mode 100644
index 000000000000..10a1a94bf40f
--- /dev/null
+++ b/meson-drop-unused-argument.patch
@@ -0,0 +1,27 @@
+From e5c5d88f95b0fe4145c9ed346b8ca98a613d7cfe Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Tue, 18 Jan 2022 16:19:32 +0000
+Subject: [PATCH] meson: drop unused argument for i18n.merge_file()
+
+Ignored in Meson < 0.60.0, deprecated since 0.60.1 and fatal since 0.61.0.
+
+data/meson.build:3:0: ERROR: Function does not take positional arguments.
+---
+ data/meson.build | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index b3c7674..2a0f42c 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -1,7 +1,6 @@
+ desktop_conf = configuration_data()
+ desktop_conf.set('APP_ID', app_id)
+ desktop_file = i18n.merge_file(
+- 'desktop',
+ input: configure_file(
+ input: 'org.gnome.Solanum.desktop.in.in',
+ output: 'org.gnome.Solanum.desktop.in',
+--
+GitLab
+