summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2020-10-23 11:28:16 -0300
committerRafael Fontenelle2020-10-23 11:28:16 -0300
commitb53d2f0e8bebacb074d7e5909b320252fe090143 (patch)
tree230502c421848761f8a4f30eb61d6619323362ed
downloadaur-b53d2f0e8bebacb074d7e5909b320252fe090143.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore22
-rw-r--r--PKGBUILD32
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0366fbdf3a03
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = solanum
+ pkgdesc = A pomodoro timer for the GNOME desktop
+ pkgver = v1.1.0.r0.g9804c7b
+ pkgrel = 1
+ url = https://gitlab.gnome.org/World/solanum
+ arch = x86_64
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = rust
+ makedepends = meson
+ makedepends = git
+ depends = gst-plugins-bad-libs
+ depends = libhandy
+ source = git+https://gitlab.gnome.org/World/solanum#commit=9804c7bab1de46fb14bdd24784cecfa09c0fff5b
+ md5sums = SKIP
+
+pkgname = solanum
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ddfe915b4f92
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,22 @@
+# ignore everything ...
+*
+
+# ... except itself
+!.gitignore
+
+# ... except changes in package
+!PKGBUILD
+!.SRCINFO
+
+# ... except possible source files
+!*.patch
+!*.diff
+!*.desktop
+!*.png
+!LICENSE
+!*.service
+!*.conf
+
+# ... except files from PKGBUILD fields
+!*.changelog
+!*.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..257b7b984bd0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
+pkgname=solanum
+pkgver=v1.1.0.r0.g9804c7b
+pkgrel=1
+pkgdesc="A pomodoro timer for the GNOME desktop"
+arch=(x86_64)
+url="https://gitlab.gnome.org/World/solanum"
+license=('GPL3')
+depends=('gst-plugins-bad-libs' 'libhandy')
+makedepends=('rust' 'meson' 'git')
+checkdepends=('appstream-glib')
+_commit=9804c7bab1de46fb14bdd24784cecfa09c0fff5b
+source=("git+$url#commit=$_commit")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson $pkgname build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}