summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2023-09-01 13:12:59 -0300
committerRafael Fontenelle2023-09-01 13:14:14 -0300
commitd5a17871ff67936ade5e768d8e7f8a95d2437e72 (patch)
treeaef0c7f0810d623ba9249ea1f86673026df0d742
parentbefa18f70a12476f61a636894a2184729d6e594d (diff)
downloadaur-d5a17871ff67936ade5e768d8e7f8a95d2437e72.tar.gz
Update to 4.0.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
-rw-r--r--force-release-build.diff13
-rw-r--r--meson-drop-unused-argument.patch27
4 files changed, 12 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecf45dbf710d..fa72b5e84fe3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = solanum
pkgdesc = A pomodoro timer for the GNOME desktop
- pkgver = 3.0.1.r0.g3f84b1d
- pkgrel = 3
+ pkgver = 4.0.0
+ pkgrel = 1
url = https://gitlab.gnome.org/World/solanum
arch = x86_64
license = GPL3
checkdepends = appstream-glib
+ makedepends = blueprint-compiler
makedepends = cargo
makedepends = meson
makedepends = git
depends = libadwaita
depends = gst-plugins-bad-libs
- source = git+https://gitlab.gnome.org/World/solanum#commit=3f84b1d0c46fe1a3daef2940b1d0747222023984
- source = meson-drop-unused-argument.patch
- source = force-release-build.diff
+ source = git+https://gitlab.gnome.org/World/solanum#commit=33c01f8a2da39cba0bc1744e405de2be833876cd
sha256sums = SKIP
- sha256sums = e2d30fb22bb8948659d909064df462bd74f44f2eb768757d041618aecb36b245
- sha256sums = 6abe8cf8013af7ce2edef14dddeb35fe9be8f1e4ad854301e29f4e708f521d42
pkgname = solanum
diff --git a/PKGBUILD b/PKGBUILD
index 8abb88bfcf8c..f49765b5a3ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,25 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
pkgname=solanum
-pkgver=3.0.1.r0.g3f84b1d
-pkgrel=3
+pkgver=4.0.0
+pkgrel=1
pkgdesc="A pomodoro timer for the GNOME desktop"
arch=(x86_64)
url="https://gitlab.gnome.org/World/solanum"
license=('GPL3')
depends=('libadwaita' 'gst-plugins-bad-libs')
-makedepends=('cargo' 'meson' 'git')
+makedepends=('blueprint-compiler' 'cargo' 'meson' 'git')
checkdepends=('appstream-glib')
-_commit=3f84b1d0c46fe1a3daef2940b1d0747222023984 # tags/v3.0.1
-source=("git+$url#commit=$_commit"
- meson-drop-unused-argument.patch
- force-release-build.diff)
-sha256sums=('SKIP'
- 'e2d30fb22bb8948659d909064df462bd74f44f2eb768757d041618aecb36b245'
- '6abe8cf8013af7ce2edef14dddeb35fe9be8f1e4ad854301e29f4e708f521d42')
+_commit=33c01f8a2da39cba0bc1744e405de2be833876cd # releases/v4.0.0
+source=("git+$url#commit=$_commit")
+sha256sums=('SKIP')
prepare() {
cd $pkgname
- git apply "$srcdir/meson-drop-unused-argument.patch"
- # Make sure cargo runs as release buildtype instead of debug
- git apply "$srcdir/force-release-build.diff"
}
pkgver() {
cd $pkgname
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/^v//;s/-/./g'
+ git describe --tags
}
build() {
@@ -35,7 +28,7 @@ build() {
}
check() {
- meson test -C build
+ meson test -C build --print-errorlogs
}
package() {
diff --git a/force-release-build.diff b/force-release-build.diff
deleted file mode 100644
index fb3b7e9906bb..000000000000
--- a/force-release-build.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/build-aux/cargo.sh b/build-aux/cargo.sh
-index b37435f..5b666ae 100644
---- a/build-aux/cargo.sh
-+++ b/build-aux/cargo.sh
-@@ -9,7 +9,7 @@ export BUILDTYPE="$4"
- export APP_BIN="$5"
-
-
--if [ $BUILDTYPE = "release" ]
-+if [ $BUILDTYPE = "plain" ]
- then
- echo "RELEASE MODE"
- cargo build --manifest-path \
diff --git a/meson-drop-unused-argument.patch b/meson-drop-unused-argument.patch
deleted file mode 100644
index 10a1a94bf40f..000000000000
--- a/meson-drop-unused-argument.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From e5c5d88f95b0fe4145c9ed346b8ca98a613d7cfe Mon Sep 17 00:00:00 2001
-From: Jan Beich <jbeich@FreeBSD.org>
-Date: Tue, 18 Jan 2022 16:19:32 +0000
-Subject: [PATCH] meson: drop unused argument for i18n.merge_file()
-
-Ignored in Meson < 0.60.0, deprecated since 0.60.1 and fatal since 0.61.0.
-
-data/meson.build:3:0: ERROR: Function does not take positional arguments.
----
- data/meson.build | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/data/meson.build b/data/meson.build
-index b3c7674..2a0f42c 100644
---- a/data/meson.build
-+++ b/data/meson.build
-@@ -1,7 +1,6 @@
- desktop_conf = configuration_data()
- desktop_conf.set('APP_ID', app_id)
- desktop_file = i18n.merge_file(
-- 'desktop',
- input: configure_file(
- input: 'org.gnome.Solanum.desktop.in.in',
- output: 'org.gnome.Solanum.desktop.in',
---
-GitLab
-