summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom van Dijk2021-12-30 19:05:53 +0100
committerTom van Dijk2022-04-27 15:48:40 +0200
commit6a552aae8a09748c3568db0a215c28da40a1fa56 (patch)
tree47c3ea64eaabef8300ba1fbbebf292d4fa91985d
downloadaur-6a552aae8a09748c3568db0a215c28da40a1fa56.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rwxr-xr-xPKGBUILD38
-rw-r--r--solartweaks.desktop7
4 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2040ae1a6233
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = solar-tweaks-bin
+ pkgdesc = Solar Tweaks is a tool for tweaking and customizing Lunar Client. Give yourself an upgrade in your gaming experience.
+ pkgver = 4.0.1
+ pkgrel = 1
+ url = https://github.com/Solar-Tweaks/Solar-Tweaks
+ arch = x86_64
+ license = GPL3
+ depends = alsa-lib
+ depends = atk
+ depends = gtk3
+ depends = nss
+ provides = solar-tweaks
+ options = !strip
+ source = https://github.com/Solar-Tweaks/Solar-Tweaks/releases/download/v4.0.1/Solar-Tweaks-4.0.1.AppImage
+ sha256sums = SKIP
+
+pkgname = solar-tweaks-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e311d4563862
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.AppImage
+/pkg
+/src
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..5b2e457742bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: dtomvan <18gatenmaker6 at gmail dot com>
+
+_pkgname='solar-tweaks'
+pkgname="${_pkgname}-bin"
+pkgdesc="Solar Tweaks is a tool for tweaking and customizing Lunar Client. Give yourself an upgrade in your gaming experience. "
+pkgver=4.0.1
+_appimage="Solar-Tweaks-$pkgver.AppImage"
+pkgrel=1
+depends=('alsa-lib' 'atk' 'gtk3' 'nss')
+optdepends=()
+arch=('x86_64')
+url="https://github.com/Solar-Tweaks/Solar-Tweaks"
+license=('GPL3')
+provides=(${_pkgname})
+options=(!strip)
+conflicts=()
+source=(
+ https://github.com/Solar-Tweaks/Solar-Tweaks/releases/download/v$pkgver/$_appimage
+)
+sha256sums=(SKIP)
+
+prepare () {
+ cd "$srcdir"
+ chmod +x $_appimage
+ ./$_appimage --appimage-extract
+}
+
+package() {
+ cd "$srcdir"
+
+ install -Dm755 ../$_appimage "$pkgdir/opt/solartweaks/$_appimage"
+ install -dm755 "$pkgdir/usr/bin"
+
+ ln -s "/opt/solartweaks/$_appimage" "$pkgdir/usr/bin/solartweaks"
+
+ install -Dm644 "$startdir/solartweaks.desktop" "$pkgdir/usr/share/applications/solartweaks.desktop"
+ install -Dm644 "squashfs-root/solartweaks.png" "$pkgdir/usr/share/pixmaps/solartweaks.png"
+}
diff --git a/solartweaks.desktop b/solartweaks.desktop
new file mode 100644
index 000000000000..d704756c71de
--- /dev/null
+++ b/solartweaks.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Solar Tweaks
+Comment=Solar Tweaks
+Exec=solartweaks
+Icon=solartweaks
+Categories=Game;