summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVardanHeroic2023-12-05 22:52:49 +0400
committerVardanHeroic2023-12-05 22:52:49 +0400
commit578b9f8a8d9b62938e0f00eb6e370d4b4414c539 (patch)
tree684b3fa68c3fa484398c93d0b45de0cf43372b49
parent15dc7af440a93857574d8b1859440b636525fddc (diff)
downloadaur-578b9f8a8d9b62938e0f00eb6e370d4b4414c539.tar.gz
changed installation method
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
2 files changed, 14 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3fefcc68e365..3d31e07f4295 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
-pkgbase = solarbg-git
+pkgbase = solarbg
pkgdesc = Sun altitude based wallpapers
- pkgver = v1.2.0.r0.gb4bd1bf
- pkgrel = 4
+ pkgver = 1.3.1
+ pkgrel = 5
url = https://github.com/VardanHeroic/solarbg
arch = x86_64
license = GPL
@@ -10,7 +10,9 @@ pkgbase = solarbg-git
depends = nodejs>=16.0.0
optdepends = feh: x11 tiling wm support,
optdepends = swaybg: wlroots based wayland compositors support
- source = solarbg-git::git+https://github.com/VardanHeroic/solarbg.git
+ replaces = solarbg-git
+ noextract = -1.3.1.tgz
+ source = https://registry.npmjs.org/solarbg/-/solarbg-1.3.1.tgz
md5sums = SKIP
-pkgname = solarbg-git
+pkgname = solarbg
diff --git a/PKGBUILD b/PKGBUILD
index 60082ac87758..12a0d742073b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vardan Tarayan <tarayanvardan@gmail.com>
-pkgname='solarbg-git'
-pkgrel=4
-pkgver="v1.2.0.r0.gb4bd1bf"
+pkgname='solarbg'
+pkgrel=5
+pkgver=1.3.1
pkgdesc="Sun altitude based wallpapers "
arch=('x86_64')
url="https://github.com/VardanHeroic/solarbg"
@@ -11,29 +11,13 @@ makedepends=('git' 'npm')
optdepends=(
'feh: x11 tiling wm support',
'swaybg: wlroots based wayland compositors support')
-source=('solarbg-git::git+https://github.com/VardanHeroic/solarbg.git')
+source=('https://registry.npmjs.org/solarbg/-/solarbg-1.3.1.tgz')
+replaces=('solarbg-git')
md5sums=('SKIP')
+noextract=("${_pkgname}-${pkgver}.tgz")
-pkgver() {
- cd "$pkgname"
- git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-build() {
- cd "$pkgname"
- npm install --production
-}
-
package() {
- cd "$pkgname"
- appdir=/usr/lib/${pkgname}
- bindir=/usr/bin/
-
- install -d "${pkgdir}"${appdir}
- cp -r * "${pkgdir}"${appdir}
-
- install -d "${pkgdir}"${bindir}
- cp scripts/solarbg "${pkgdir}"${bindir}
+ npm install -g --prefix "${pkgdir}/usr" "${srcdir}/${pkgname}-${pkgver}.tgz"
}