summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenObiWan2015-08-14 07:43:33 +0100
committerBenObiWan2015-08-14 07:43:33 +0100
commit30491e63de73c4f93c75c1be139bb1ede83a92ea (patch)
tree4f72740ac113aca213cf26209ab0c5947e46be86
parentc25cea043a10f99fb8c782e4b601488c6d460925 (diff)
downloadaur-30491e63de73c4f93c75c1be139bb1ede83a92ea.tar.gz
Update to solarus 1.4.3
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71b2f7ffea4b..d0e8f5d98670 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Huulivoide
# Contributor: Fernando Carmona Varo <ferkiwi @t gmail dot com>
pkgname=solarus
-pkgver=1.4.2
-pkgrel=2
+pkgver=1.4.3
+pkgrel=1
epoch=
pkgdesc="An open-source Zelda-like 2D game engine used by the games zsxd and zsdx."
arch=('i686' 'x86_64')
@@ -15,7 +15,7 @@ groups=()
depends=('luajit' 'sdl2_image' 'sdl2_ttf' 'physfs' 'openal' 'libvorbis' 'libmodplug')
makedepends=('cmake' 'zip')
checkdepends=()
-optdepends=('zsxd' 'zsdx')
+optdepends=('zsxd' 'zsdx' 'zelda-roth-se')
provides=('solarus-engine')
conflicts=('zsdxdemo-en' 'zsdxdemo-de' 'zsdxdemo-fr' 'solarus-git')
replaces=('zsdxdemo-en' 'zsdxdemo-de' 'zsdxdemo-fr' 'solarus-git')
@@ -25,15 +25,11 @@ install=
changelog=
source=(http://www.zelda-solarus.com/downloads/$pkgname/$pkgname-$pkgver-src.tar.gz)
noextract=()
-md5sums=('305ac13dc2c32d35a9effd4e4ed2b2b0')
+md5sums=('1de773fb5f23c3066775caf5d57bd9ab')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- #fix wrong version number of 1.4.2 source
- sed -i 's/SOLARUS_MINOR_VERSION 5/SOLARUS_MINOR_VERSION 4/' include/solarus/Common.h
- sed -i 's/SOLARUS_PATCH_VERSION 0/SOLARUS_PATCH_VERSION 2/' include/solarus/Common.h
-
cmake -D CMAKE_INSTALL_PREFIX="/usr" -D CMAKE_BUILD_TYPE=Release -D DEFAULT_QUEST=/usr/share/solarus/zsdx .
make
}