summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfranck.stauffer2021-03-03 02:00:46 +0100
committerfranck.stauffer2021-03-03 02:00:46 +0100
commit7e7f0519b2d34f8882e7081abfc5ffeca7c25f10 (patch)
treed2f8354716f55be23928998e32132384dd072fbf
parent63ec5d054d33e2938d8caa9ea5dcd6bfb5dd03f8 (diff)
downloadaur-7e7f0519b2d34f8882e7081abfc5ffeca7c25f10.tar.gz
Update to 1.7.0.dev.1045101871
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 840e3b726a9b..99183b43b147 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = solarus-bin
pkgdesc = A lightweight, free and open-source game engine for Action-RPGs
- pkgver = 1.7.0.dev.1029181599
+ pkgver = 1.7.0.dev.1045101871
pkgrel = 1
- url = http://www.solarus-games.org/
+ url = https://gitlab.com/solarus-games/solarus
arch = x86_64
license = GPL3
+ makedepends = unzip
depends = glm
depends = hicolor-icon-theme
depends = libmodplug>=0.8.8.4
@@ -20,8 +21,8 @@ pkgbase = solarus-bin
conflicts = solarus
conflicts = solarus-run
conflicts = solarus-git
- source = 1029181599::https://gitlab.com/solarus-games/solarus/-/jobs/1029181599/artifacts/download
- md5sums = 0ad717c177de97cfc98e9d86cd809752
+ source = solarus-bin-1.7.0.dev.1045101871.zip::https://gitlab.com/solarus-games/solarus/-/jobs/1045101871/artifacts/download
+ b2sums = c52a43b858890595a525efe4b5ec71c21c991abe87cdf1dae591d3fc916d433b04e246727452a0719590635730654cdf1126279b5e673df42547fbfbc2e4233d
pkgname = solarus-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1a384dd02c78..4f51ed2cff80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,13 @@
# Maintainer: Hydral <nathan.dacunha.nd@gmail.com>
+# Co-maintainer: Franck STAUFFER <franck.stauffer@monaco.mc>
+_jobId=1045101871
pkgname=solarus-bin
-pkgver=1.7.0.dev.1029181599
+pkgver=1.7.0.dev.$_jobId
pkgrel=1
arch=('x86_64')
-pkgdesc="A lightweight, free and open-source game engine for Action-RPGs"
-url="http://www.solarus-games.org/"
+pkgdesc='A lightweight, free and open-source game engine for Action-RPGs'
+url='https://gitlab.com/solarus-games/solarus'
license=('GPL3')
depends=('glm'
'hicolor-icon-theme'
@@ -18,12 +20,16 @@ depends=('glm'
'sdl2>=2.0.6'
'sdl2_image'
'sdl2_ttf')
-source=("1029181599::https://gitlab.com/solarus-games/solarus/-/jobs/1029181599/artifacts/download")
+makedepends=('unzip')
+source=("$pkgname-$pkgver.zip::https://gitlab.com/solarus-games/solarus/-/jobs/$_jobId/artifacts/download")
provides=('solarus')
conflicts=('solarus' 'solarus-run' 'solarus-git')
+b2sums=('c52a43b858890595a525efe4b5ec71c21c991abe87cdf1dae591d3fc916d433b04e246727452a0719590635730654cdf1126279b5e673df42547fbfbc2e4233d')
+
package() {
- mkdir -p "$pkgdir/usr"
- cd $srcdir
- mv staging/* $pkgdir/usr
+ cd "$srcdir/staging"
+ install -dm755 "$pkgdir/usr"
+ mv * "$pkgdir/usr"
}
-md5sums=('0ad717c177de97cfc98e9d86cd809752')
+
+# vim:set sw=2 et: