summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2018-06-13 16:36:12 +0200
committerCarsten Teibes2018-06-13 16:36:12 +0200
commit5c035551449f524f6c9ea9c00767603a93e98582 (patch)
tree8fac9e67f3752525073520ba4fc6131788e3ad6c
parenteea78dec540b7caa3db91bdcbbe87bacda84ab00 (diff)
downloadaur-5c035551449f524f6c9ea9c00767603a93e98582.tar.gz
[fix] deps & urls, revamp
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
2 files changed, 32 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd081852bf10..e23fa29b5a52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = solarus-git
- pkgdesc = An open-source Zelda-like 2D game engine used by the games zsxd and zsdx (development version)
- pkgver = 1.5.0.r81.gd0601b4
+ pkgdesc = An open-source adventure 2D game engine (development version)
+ pkgver = 1.5.3.r380.gfd4a0e295
pkgrel = 1
- url = http://www.solarus-engine.org/
+ url = http://www.solarus-games.org/
arch = i686
arch = x86_64
license = GPL3
makedepends = git
makedepends = cmake
+ makedepends = ninja
+ makedepends = qt5-tools
+ makedepends = glm
depends = sdl2_image
depends = sdl2_ttf
depends = luajit
@@ -15,12 +18,18 @@ pkgbase = solarus-git
depends = openal
depends = libmodplug
depends = libvorbis
- optdepends = zsxd-git: Free 2D Zelda fangame Quest
- optdepends = zsdx-git: Free 2D Zelda fangame Quest with humoristic characters
+ depends = hicolor-icon-theme
+ depends = qt5-base
+ optdepends = zsdx-git: Free 2D Zelda fangame
+ optdepends = zsxd-git: Parodic Zelda fangame
+ optdepends = zelda-mercuris-chest: Zelda fangame (in development)
+ optdepends = zelda-xd2: April Fools game
+ optdepends = zelda-roth-se: Remake of Zelda Return of the Hylian
+ optdepends = zelda-olb-se: Remake of Zelda Oni Link Begins
provides = solarus-engine
provides = solarus
conflicts = solarus
- source = solarus-git::git+https://github.com/christopho/solarus.git
+ source = solarus-git::git+https://gitlab.com/solarus-games/solarus.git
md5sums = SKIP
pkgname = solarus-git
diff --git a/PKGBUILD b/PKGBUILD
index d6977e8e9473..a09c44d92444 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,24 @@
# Contributor: BenObiWan <benobiwan @t gmail dot com>
pkgname=solarus-git
-pkgver=1.5.0.r81.gd0601b4
+pkgver=1.5.3.r380.gfd4a0e295
pkgrel=1
-pkgdesc="An open-source Zelda-like 2D game engine used by the games zsxd and zsdx (development version)"
+pkgdesc="An open-source adventure 2D game engine (development version)"
arch=('i686' 'x86_64')
-url="http://www.solarus-engine.org/"
+url="http://www.solarus-games.org/"
license=('GPL3')
-depends=('sdl2_image' 'sdl2_ttf' 'luajit' 'physfs' 'openal' 'libmodplug' 'libvorbis')
-makedepends=('git' 'cmake')
-optdepends=('zsxd-git: Free 2D Zelda fangame Quest'
- 'zsdx-git: Free 2D Zelda fangame Quest with humoristic characters')
+depends=('sdl2_image' 'sdl2_ttf' 'luajit' 'physfs' 'openal' 'libmodplug' 'libvorbis'
+ 'hicolor-icon-theme' 'qt5-base')
+makedepends=('git' 'cmake' 'ninja' 'qt5-tools' 'glm')
+optdepends=('zsdx-git: Free 2D Zelda fangame'
+ 'zsxd-git: Parodic Zelda fangame'
+ 'zelda-mercuris-chest: Zelda fangame (in development)'
+ 'zelda-xd2: April Fools game'
+ 'zelda-roth-se: Remake of Zelda Return of the Hylian'
+ 'zelda-olb-se: Remake of Zelda Oni Link Begins')
provides=('solarus-engine' 'solarus')
conflicts=('solarus')
-source=($pkgname::'git+https://github.com/christopho/solarus.git')
+source=($pkgname::'git+https://gitlab.com/solarus-games/solarus.git')
md5sums=('SKIP')
pkgver() {
@@ -36,14 +41,14 @@ prepare() {
build() {
cd $pkgname/build
- cmake .. -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=Release
- make
+ cmake .. -GNinja -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=Release
+ ninja
}
check() {
- make -C $pkgname/build test
+ ninja -C $pkgname/build test
}
package() {
- make -C $pkgname/build DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir/" ninja -C $pkgname/build install
}