summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2016-10-29 15:33:21 +0200
committerCarsten Teibes2016-10-29 15:33:21 +0200
commiteea78dec540b7caa3db91bdcbbe87bacda84ab00 (patch)
tree16a5101da47b8b562404439fe9af9501f8d2044a
parent533baf5c0a0ee3541a652a4a99c21db74c985f5e (diff)
downloadaur-eea78dec540b7caa3db91bdcbbe87bacda84ab00.tar.gz
[upd]
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ccf7b23c231..cd081852bf10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = solarus-git
pkgdesc = An open-source Zelda-like 2D game engine used by the games zsxd and zsdx (development version)
- pkgver = 1.3.0.r610.g227aa56
+ pkgver = 1.5.0.r81.gd0601b4
pkgrel = 1
url = http://www.solarus-engine.org/
arch = i686
@@ -15,8 +15,8 @@ pkgbase = solarus-git
depends = openal
depends = libmodplug
depends = libvorbis
- optdepends = zsxd-git: Default Quest
- optdepends = zsdx-git: Another Quest
+ optdepends = zsxd-git: Free 2D Zelda fangame Quest
+ optdepends = zsdx-git: Free 2D Zelda fangame Quest with humoristic characters
provides = solarus-engine
provides = solarus
conflicts = solarus
diff --git a/PKGBUILD b/PKGBUILD
index c01c312b19b2..d6977e8e9473 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: BenObiWan <benobiwan @t gmail dot com>
pkgname=solarus-git
-pkgver=1.3.0.r610.g227aa56
+pkgver=1.5.0.r81.gd0601b4
pkgrel=1
pkgdesc="An open-source Zelda-like 2D game engine used by the games zsxd and zsdx (development version)"
arch=('i686' 'x86_64')
@@ -11,8 +11,8 @@ url="http://www.solarus-engine.org/"
license=('GPL3')
depends=('sdl2_image' 'sdl2_ttf' 'luajit' 'physfs' 'openal' 'libmodplug' 'libvorbis')
makedepends=('git' 'cmake')
-optdepends=('zsxd-git: Default Quest'
- 'zsdx-git: Another Quest')
+optdepends=('zsxd-git: Free 2D Zelda fangame Quest'
+ 'zsdx-git: Free 2D Zelda fangame Quest with humoristic characters')
provides=('solarus-engine' 'solarus')
conflicts=('solarus')
source=($pkgname::'git+https://github.com/christopho/solarus.git')
@@ -20,7 +20,10 @@ md5sums=('SKIP')
pkgver() {
cd $pkgname
- git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+ local _tag=$(git tag -l 'v*' | sort -r | head -n1 | tr -cd 0-9.)
+ local _rev=$(git rev-list --count v${_tag}..HEAD)
+ local _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash"
}
prepare() {
@@ -28,16 +31,12 @@ prepare() {
rm -rf build
mkdir build
-
- # small fix
- sed 's/"${SDL2MAIN_LIBRARY}"//' -i tests/CMakeLists.txt
}
build() {
cd $pkgname/build
- cmake .. -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=Release \
- -DDEFAULT_QUEST=/usr/share/solarus/zsdx
+ cmake .. -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=Release
make
}
@@ -47,7 +46,4 @@ check() {
package() {
make -C $pkgname/build DESTDIR="$pkgdir/" install
-
- # provide compatibility with old quest packages
- ln -s solarus_run "$pkgdir"/usr/bin/solarus
}