summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxs17892015-07-10 07:33:39 +0200
committerMaxs17892015-07-10 07:33:39 +0200
commit034b2ff5b7b95886ba8fcca60829e79df20c3baa (patch)
treed50f21813eb421d1785995e6bac3a6984d0c1545
downloadaur-034b2ff5b7b95886ba8fcca60829e79df20c3baa.tar.gz
First commit. (v1.4.2)
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
-rw-r--r--solarus-quest-editor.desktop7
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0849fe2ac77
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 4.2.1
+# Fri Jul 10 05:09:30 UTC 2015
+pkgbase = solarus-quest-editor
+ pkgver = 1.4.2
+ pkgrel = 1
+ url = http://www.solarus-engine.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ makedepends = cmake
+ makedepends = zip
+ depends = solarus
+ depends = qt5-base
+ depends = qt5-tools
+ source = https://github.com/christopho/solarus-quest-editor/archive/v1.4.2.tar.gz
+ source = solarus-quest-editor.desktop
+ md5sums = e8cad3ca7cbe741c4270e57317887933
+ md5sums = 4ff37fa2155d1bb4586c4f964f2736f4
+
+pkgname = solarus-quest-editor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05dbbf1cbdf5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Maxs <max dot van dot den dot branden @t gmail dot com>
+pkgname=solarus-quest-editor
+pkgver=1.4.2
+pkgrel=1
+epoch=
+pkgdesc="A graphical user interface to create and modify quests for the Solarus engine."
+arch=(i686 x86_64)
+url=http://www.solarus-games.org/
+license=(GPL custom)
+groups=()
+depends=(solarus qt5-base qt5-tools)
+makedepends=(cmake zip)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://github.com/christopho/$pkgname/archive/v$pkgver.tar.gz $pkgname.desktop)
+noextract=()
+md5sums=(e8cad3ca7cbe741c4270e57317887933 38afc75a98448ddc6470f1efa41d7904)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ cmake -D CMAKE_BUILD_TYPE=Release .
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "images/logo/sqe-logo.png" "$pkgdir/usr/share/pixmaps/sqe-logo.png"
+ install -Dm644 "license.txt" "$pkgdir/usr/share/licences/$pkgname/license.txt"
+
+ cd "$startdir"
+
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
+
diff --git a/solarus-quest-editor.desktop b/solarus-quest-editor.desktop
new file mode 100644
index 000000000000..d8254ec45bff
--- /dev/null
+++ b/solarus-quest-editor.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Solarus Quest Editor
+Comment=A graphical user interface to create and modify quests for the Solarus engine.
+Exec=/usr/bin/solarus-quest-editor
+Icon=/usr/share/pixmaps/sqe-logo.png
+Categories=Development;