summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Knapp2020-05-26 20:41:02 -0700
committerJonathan Knapp2020-05-26 20:41:52 -0700
commit458018bb37acbaee8b47a22dfa7c119ca7971ac3 (patch)
treecb6fca023e2707cce9c02d15b0f79e39600fd3e9
parent9c0da75aff3ec48e608443b40cf920b75d12c700 (diff)
downloadaur-458018bb37acbaee8b47a22dfa7c119ca7971ac3.tar.gz
Added desktop file
-rw-r--r--PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 36a747f0e112..78f44dbb984e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -49,6 +49,18 @@ EOF
#!/usr/bin/env sh
$_installdir/soldatserver_x64 -fs_userpath ~/.local/share/Soldat/Soldat \$@
EOF
+
+ # create desktop file
+ cat <<EOF > soldat.desktop
+[Desktop Entry]
+Type=Application
+Name=Soldat
+Exec=soldat -joinurl %u
+Icon=$_installdir/soldat.ico
+StartupNotify=false
+Terminal=false
+MimeType=x-scheme-handler/soldat;
+EOF
}
package() {
@@ -57,8 +69,10 @@ package() {
install -Dm 655 "server/build/soldatserver_x64" -t "$pkgdir/$_installdir";
install -Dm 655 "client/build/soldat_x64" -t "$pkgdir/$_installdir";
install -Dm 644 "client/build/libstb.so" -t "$pkgdir/$_installdir";
+ install -Dm 644 "client/media/soldat.ico" -t "$pkgdir/$_installdir";
install -Dm 644 "$srcdir/soldat-base/soldat.smod" -t "$pkgdir/$_installdir";
install -Dm 644 "$srcdir/soldat-base/client/play-regular.ttf" -t "$pkgdir/$_installdir";
install -Dm 655 "soldat" -t "$pkgdir/usr/bin";
install -Dm 655 "soldatserver" -t "$pkgdir/usr/bin";
+ install -Dm 655 "soldat.desktop" -t "$pkgdir/usr/share/applications";
}