summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2019-03-31 23:03:58 -0700
committermutantmonkey2019-03-31 23:03:58 -0700
commit49d77e823fe84022704c35b1243dde01c7ec2ea9 (patch)
tree12b30ada410bad641d2eaf8a42b40781cb9282cf
downloadaur-49d77e823fe84022704c35b1243dde01c7ec2ea9.tar.gz
Initial upload: solo-python 0.0.9-1
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD27
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c707f528382
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = solo-python
+ pkgdesc = Tools and Python library for SoloKeys.
+ pkgver = 0.0.9
+ pkgrel = 1
+ url = https://github.com/solokeys/solo-python
+ arch = any
+ license = Apache
+ license = MIT
+ makedepends = python-pip
+ makedepends = flit
+ depends = python
+ depends = python-click>=7.0
+ depends = python-cryptography
+ depends = python-ecdsa
+ depends = python-fido2
+ depends = python-intelhex
+ depends = python-pyserial
+ depends = python-pyusb
+ depends = python-requests
+ source = https://files.pythonhosted.org/packages/source/s/solo-python/solo-python-0.0.9.tar.gz
+ sha256sums = 0de0105e53637c6ba8753dcc02cd504f6424c34cc77373219793b5c0d7a832c4
+
+pkgname = solo-python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6415f2efddae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: mutantmonkey <aur@mutantmonkey.mx>
+pkgname=solo-python
+pkgver=0.0.9
+pkgrel=1
+pkgdesc="Tools and Python library for SoloKeys."
+arch=('any')
+url="https://github.com/solokeys/solo-python"
+license=('Apache' 'MIT')
+depends=('python' 'python-click>=7.0' 'python-cryptography' 'python-ecdsa'
+ 'python-fido2' 'python-intelhex' 'python-pyserial' 'python-pyusb'
+ 'python-requests')
+makedepends=('python-pip' 'flit')
+source=("https://files.pythonhosted.org/packages/source/s/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('0de0105e53637c6ba8753dcc02cd504f6424c34cc77373219793b5c0d7a832c4')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ flit build --format wheel
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm 644 LICENSE-MIT \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ pip install -I --no-warn-script-location --isolated --no-deps --compile \
+ --root="${pkgdir}" dist/${pkgname/-/_}-${pkgver}-py3-none-any.whl
+}