summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2021-03-27 14:42:40 -0700
committermutantmonkey2021-03-27 14:42:40 -0700
commit8936aac2a80a37a5d26e695fb44d9d7749bcc0f0 (patch)
tree090007e71940e1134e5cd6da7bde65790725245b
parent2e39a35bc0994ab789f6db7f6c6ebbfc7ad4d234 (diff)
downloadaur-8936aac2a80a37a5d26e695fb44d9d7749bcc0f0.tar.gz
upgpkg: solo-python 0.0.27-3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63125f40a180..9c5c60306993 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = solo-python
pkgdesc = Tools and Python library for SoloKeys.
pkgver = 0.0.27
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/solokeys/solo-python
arch = any
license = Apache
license = MIT
makedepends = python-pip
- makedepends = flit
+ makedepends = python-flit
depends = python
depends = python-click>=7.0
depends = python-cryptography
diff --git a/PKGBUILD b/PKGBUILD
index 2e4e80a831ce..11dc6fde89b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: mutantmonkey <aur@mutantmonkey.mx>
pkgname=solo-python
pkgver=0.0.27
-pkgrel=2
+pkgrel=3
pkgdesc="Tools and Python library for SoloKeys."
arch=('any')
url="https://github.com/solokeys/solo-python"
@@ -9,13 +9,13 @@ license=('Apache' 'MIT')
depends=('python' 'python-click>=7.0' 'python-cryptography' 'python-ecdsa'
'python-fido2' 'python-intelhex' 'python-pyserial' 'python-pyusb'
'python-requests')
-makedepends=('python-pip' 'flit')
+makedepends=('python-pip' 'python-flit')
source=("https://files.pythonhosted.org/packages/source/s/${pkgname}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('72a4699eb3b1979d7a2561c538987f868b5e7ee4e4a5b402b8a4d460d3dd6ec7')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- flit build --format wheel
+ python -m flit build --format wheel
}
package() {