summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Stalder2021-11-15 01:13:23 +0100
committerNicolas Stalder2021-11-21 02:54:01 +0100
commit9da1cbeaa84ce7f14ddc45db37768ffdfa65ccaa (patch)
treef8f575734eac1d003f98265df9a6eb3557dd0528
parentc223a8085c19f77219daf972f0e1cee86f718b97 (diff)
downloadaur-9da1cbeaa84ce7f14ddc45db37768ffdfa65ccaa.tar.gz
Model things and separate concerns
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a711bb312a7..0d43954088c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,37 @@
# Maintainer: Nicolas Stalder <n+archlinux@stalder.io>
pkgname=solo2-cli
-pkgver=0.0.6
-_pkgver=0.0.6
+pkgver=0.0.7
pkgrel=1
pkgdesc='Solo 2 CLI'
arch=('x86_64')
url="https://github.com/solokeys/solo2-cli"
license=(Apache MIT)
# we only need `libudev.so`, during build we also need `pkgconfig/udev/.pc`
-depends=(systemd-libs)
+depends=(systemd-libs ccid)
# note we do not need Arch `hidapi` package here, it's a git submodule of Rust hidapi
makedepends=(cargo git systemd)
conflicts=(solo2-cli-git)
source=(
- "$pkgname-$pkgver.tar.gz::https://github.com/solokeys/solo2-cli/archive/refs/tags/v${_pkgver}.tar.gz"
+ "$pkgname.tar.gz::https://github.com/solokeys/solo2-cli/archive/refs/tags/v${pkgver}.tar.gz"
)
sha256sums=(
"083014e217779f190e49e4839ae99781c1559690a3ee5d96cbdcb1489e663049"
)
build() {
- cd "${pkgname}-${_pkgver}"
- cargo build --release --locked
+ cd "${pkgname}-${pkgver}"
+ cargo build --release --frozen
}
check() {
- cd "${pkgname}-${_pkgver}"
+ cd "${pkgname}-${pkgver}"
# make sure shared libs work
target/release/solo2 --version
cargo test --release
}
package() {
- cd "${pkgname}-${_pkgver}"
+ cd "${pkgname}-${pkgver}"
install -Dm755 target/release/solo2 "$pkgdir/usr/bin/solo2"
install -Dm644 LICENSE-MIT "$pkgdir/usr/share/licenses/$pkgnamefull/LICENSE-MIT"