summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-12-08 04:59:45 -0500
committerJames An2015-12-08 04:59:45 -0500
commit39e1aac068f36c4a2c7b0e5e542bbf9eb7022095 (patch)
treedc11c0ffcf826079e87d43d51dd5f8bc5067901b
parent44026d83dc9b3a6171f7a2d5524947a991805512 (diff)
downloadaur-39e1aac068f36c4a2c7b0e5e542bbf9eb7022095.tar.gz
Update source file to use Drupal.org URLs, changed package version to date format, changed owner for all files to root:root.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD57
2 files changed, 38 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8aeae5dd597..b1320f45eb02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Dec 7 21:50:50 UTC 2015
+# Tue Dec 8 09:57:18 UTC 2015
pkgbase = solr-conf-drupal
pkgdesc = Configuration files to enable Drupal 7.x or 8.x to use Solr 3.x, 4.x, or 5.x as its search provider
- pkgver = 1
- pkgrel = 2
+ pkgver = 20151208
+ pkgrel = 1
url = http://drupal.org/project/search_api_solr
arch = any
license = GPL
@@ -12,12 +12,15 @@ pkgbase = solr-conf-drupal
optdepends = drupal: Solr client for these configuration files
optdepends = aegir: meta-Drupal hosting platform
optdepends = solr-undertow: high performance servlet container for Solr
- source = http://ftp.drupal.org/files/projects/search_api_solr-7.x-1.8.zip
- source = https://github.com/amateescu/search_api_solr/archive/8.x-1.x.zip
+ noextract = https://raw.githubusercontent.com/apache/lucene-solr/branch_5x/solr/core/src/test-files/solr/collection1/conf/mapping-ISOLatin1Accent.txt
+ noextract = http://ftp.drupal.org/files/projects/search_api_solr-7.x-1.9.tar.gz
+ noextract = http://ftp.drupal.org/files/projects/search_api_solr-8.x-1.0-alpha1.tar.gz
source = https://raw.githubusercontent.com/apache/lucene-solr/branch_5x/solr/core/src/test-files/solr/collection1/conf/mapping-ISOLatin1Accent.txt
- md5sums = ea3f8918a37f5d581def933921870e2d
- md5sums = b3806096d1e43de09ca8c49c4c601159
+ source = http://ftp.drupal.org/files/projects/search_api_solr-7.x-1.9.tar.gz
+ source = http://ftp.drupal.org/files/projects/search_api_solr-8.x-1.0-alpha1.tar.gz
md5sums = 9f3c8a60a4f09327fad22aeff082c2b3
+ md5sums = 0293cb23527acb1e8a307539a8d68021
+ md5sums = 40fccb08f08b0014ff884504ddb7616c
pkgname = solr-conf-drupal
diff --git a/PKGBUILD b/PKGBUILD
index 75015a9505b3..96b5aa8beec2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,49 @@
# Maintainer: James An <james@jamesan.ca>
-_pkgname=solr
pkgname=solr-conf-drupal
-pkgver=1
-pkgrel=2
+_pkgname=search_api_solr
+pkgver=20151208
+_pkgvers=(7.x-1.9
+ 8.x-1.0-alpha1)
+pkgrel=1
pkgdesc="Configuration files to enable Drupal 7.x or 8.x to use Solr 3.x, 4.x, or 5.x as its search provider"
arch=('any')
-url="http://drupal.org/project/search_api_$_pkgname"
+url="http://drupal.org/project/$_pkgname"
license=('GPL')
depends=('solr>=3' 'solr<=5')
optdepends=(
'drupal: Solr client for these configuration files'
'aegir: meta-Drupal hosting platform'
- 'solr-undertow: high performance servlet container for Solr'
-)
-source=(
- "http://ftp.drupal.org/files/projects/search_api_$_pkgname-7.x-1.8.zip"
- "https://github.com/amateescu/search_api_$_pkgname/archive/8.x-1.x.zip"
- "https://raw.githubusercontent.com/apache/lucene-$_pkgname/branch_5x/$_pkgname/core/src/test-files/$_pkgname/collection1/conf/mapping-ISOLatin1Accent.txt"
- # The mapping-ISOLatin1Accent.txt file is identical in all occurrences in the Solr repo across the head of all its supported branches (3-5.x)
-)
-md5sums=('ea3f8918a37f5d581def933921870e2d'
- 'b3806096d1e43de09ca8c49c4c601159'
- '9f3c8a60a4f09327fad22aeff082c2b3')
+ 'solr-undertow: high performance servlet container for Solr')
+# The mapping-ISOLatin1Accent.txt file is identical in all occurrences in the Solr repo across the head of all its supported branches (3-5.x)
+source=("https://raw.githubusercontent.com/apache/lucene-solr/branch_5x/solr/core/src/test-files/solr/collection1/conf/mapping-ISOLatin1Accent.txt"
+ "http://ftp.drupal.org/files/projects/$_pkgname-${_pkgvers[0]}.tar.gz"
+ "http://ftp.drupal.org/files/projects/$_pkgname-${_pkgvers[1]}.tar.gz")
+md5sums=('9f3c8a60a4f09327fad22aeff082c2b3'
+ '0293cb23527acb1e8a307539a8d68021'
+ '40fccb08f08b0014ff884504ddb7616c')
+noextract=("${source[@]%%::*}")
prepare() {
- [ -d "7.x" ] && rm -rf "7.x"
- [ -d "8.x" ] && rm -rf "8.x"
- mv -f "search_api_$_pkgname" "7.x"
- mv -f "search_api_$_pkgname-8.x-1.x" "8.x"
+ for _pkgver in "${_pkgvers[@]}"; do
+ echo $_pkgver
+ ver_drupal="${_pkgver%%-*}"
+ install -dm755 "$ver_drupal"
+ tar --extract --file="$_pkgname-$_pkgver.tar.gz" --strip-components=1 --directory="$ver_drupal" --overwrite
+ done
}
package() {
- # Traverse and install conf files for Drupal 7.x and 8.x, and for Solr 3.x, 4.x, and 5.x.
- for ver_drupal in *.x; do
- for ver_solr in $(basename -a $ver_drupal/$_pkgname-conf/*); do
- for file in $(basename -a $ver_drupal/$_pkgname-conf/$ver_solr/*); do
- install -Dm644 "$ver_drupal/$_pkgname-conf/$ver_solr/$file" "$pkgdir/etc/$_pkgname/configsets/drupal-$ver_drupal-$_pkgname-$ver_solr/conf/$file"
+ # Traverse and install conf files for Drupal 7.x and 8.x, and for Solr 1.4 (Drupal 8.x only), 3.x, 4.x, and 5.x.
+ for ver_drupal in "${_pkgvers[@]%%-*}"; do
+ for ver_solr in $(basename -a $ver_drupal/solr-conf/*); do
+ for file in $(basename -a $ver_drupal/solr-conf/$ver_solr/*); do
+ install -Dm644 "$ver_drupal/solr-conf/$ver_solr/$file" "$pkgdir/etc/solr/configsets/solr-$ver_solr-drupal-$ver_drupal/conf/$file"
done
- install -Dm644 mapping-ISOLatin1Accent.txt "$pkgdir/etc/$_pkgname/configsets/drupal-$ver_drupal-$_pkgname-$ver_solr/conf/mapping-ISOLatin1Accent.txt"
+ install -Dm644 mapping-ISOLatin1Accent.txt "$pkgdir/etc/solr/configsets/solr-$ver_solr-drupal-$ver_drupal/conf/mapping-ISOLatin1Accent.txt"
done
done
-
- # Reserve uid/gid 521 for the Solr system account.
- chown 521:521 "$pkgdir/etc/$_pkgname"
}
#~ Create new core with drupal config set
-#~ http://localhost:8983/solr/admin/cores?action=CREATE&name=facet&instanceDir=/etc/solr-undertow/cores/facet&configSet=drupal-7.x-solr-5.x
+#~ http://localhost:8983/solr/admin/cores?action=CREATE&name=coreX&configSet=solr-5.x-drupal-7.x