summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-08-12 10:34:45 -0400
committerJames An2015-08-12 10:34:45 -0400
commit60fdbceee58524b81e777cd5f4ec87362610cfac (patch)
treea7ba8d0ddac870205d8730662ac2c0fb7008c508
parent05f5666efc9f620dd9a2c519ccc771a5dbe7b5fe (diff)
downloadaur-60fdbceee58524b81e777cd5f4ec87362610cfac.tar.gz
Moved Solr configuration path from /etc/solr-undertow to /etc/solr.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD35
2 files changed, 16 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acc23b9c4eb7..561612cea564 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = solr-conf-drupal
pkgdesc = Configuration files to enable Drupal 7.x or 8.x to use Solr 3.x, 4.x, or 5.x as its search provider
pkgver = 1
- pkgrel = 1
+ pkgrel = 2
url = http://drupal.org/project/search_api_solr
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 941c03a8d416..33a525dd5f9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: James An <james@jamesan.ca>
-_pkgname=search_api_solr
+_pkgname=solr
pkgname=solr-conf-drupal
pkgver=1
-pkgrel=1
+pkgrel=2
pkgdesc="Configuration files to enable Drupal 7.x or 8.x to use Solr 3.x, 4.x, or 5.x as its search provider"
arch=('any')
-url="http://drupal.org/project/$_pkgname"
+url="http://drupal.org/project/search_api_$_pkgname"
license=('GPL')
depends=('solr>=3' 'solr<=5')
optdepends=(
@@ -15,9 +15,9 @@ optdepends=(
'solr-undertow: high performance servlet container for Solr'
)
source=(
- "http://ftp.drupal.org/files/projects/$_pkgname-7.x-1.8.zip"
- "https://github.com/amateescu/$_pkgname/archive/8.x-1.x.zip"
- "https://raw.githubusercontent.com/apache/lucene-solr/branch_5x/solr/core/src/test-files/solr/collection1/conf/mapping-ISOLatin1Accent.txt"
+ "http://ftp.drupal.org/files/projects/search_api_$_pkgname-7.x-1.8.zip"
+ "https://github.com/amateescu/search_api_$_pkgname/archive/8.x-1.x.zip"
+ "https://raw.githubusercontent.com/apache/lucene-$_pkgname/branch_5x/$_pkgname/core/src/test-files/$_pkgname/collection1/conf/mapping-ISOLatin1Accent.txt"
# The mapping-ISOLatin1Accent.txt file is identical in all occurrences in the Solr repo across the head of all its supported branches (3-5.x)
)
md5sums=('ea3f8918a37f5d581def933921870e2d'
@@ -27,29 +27,24 @@ md5sums=('ea3f8918a37f5d581def933921870e2d'
prepare() {
[ -d "7.x" ] && rm -rf "7.x"
[ -d "8.x" ] && rm -rf "8.x"
- mv -f "$_pkgname" "7.x"
- mv -f "$_pkgname-8.x-1.x" "8.x"
+ mv -f "search_api_$_pkgname" "7.x"
+ mv -f "search_api_$_pkgname-8.x-1.x" "8.x"
}
package() {
# Traverse and install conf files for Drupal 7.x and 8.x, and for Solr 3.x, 4.x, and 5.x.
for ver_drupal in *.x; do
- for ver_solr in $(basename -a $ver_drupal/solr-conf/*); do
- for file in $(basename -a $ver_drupal/solr-conf/$ver_solr/*); do
- install -Dm644 "$ver_drupal/solr-conf/$ver_solr/$file" "$pkgdir/etc/solr-undertow/configsets/drupal-$ver_drupal-solr-$ver_solr/conf/$file"
+ for ver_solr in $(basename -a $ver_drupal/$_pkgname-conf/*); do
+ for file in $(basename -a $ver_drupal/$_pkgname-conf/$ver_solr/*); do
+ install -Dm644 "$ver_drupal/$_pkgname-conf/$ver_solr/$file" "$pkgdir/etc/$_pkgname/configsets/drupal-$ver_drupal-$_pkgname-$ver_solr/conf/$file"
done
- install -Dm644 mapping-ISOLatin1Accent.txt "$pkgdir/etc/solr-undertow/configsets/drupal-$ver_drupal-solr-$ver_solr/conf/mapping-ISOLatin1Accent.txt"
+ install -Dm644 mapping-ISOLatin1Accent.txt "$pkgdir/etc/$_pkgname/configsets/drupal-$ver_drupal-$_pkgname-$ver_solr/conf/mapping-ISOLatin1Accent.txt"
done
done
- chown 521:521 "$pkgdir/etc/solr-undertow"
+ # Reserve uid/gid 521 for the Solr system account.
+ chown 521:521 "$pkgdir/etc/$_pkgname"
}
-#~ solr.xml solr attributes
-#~ <bool name="shareSchema">true</bool>
-#~ <logging>
- #~ <bool name="enabled">${logging:true}</bool>
-#~ </logging>
-
#~ Create new core with drupal config set
-#~ http://localhost:8983/solr/admin/cores?action=CREATE&name=facet&instanceDir=/etc/solr-undertow/cores/facet&configSet=drupal-7.x
+#~ http://localhost:8983/solr/admin/cores?action=CREATE&name=facet&instanceDir=/etc/solr-undertow/cores/facet&configSet=drupal-7.x-solr-5.x