summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-12-07 22:03:09 -0500
committerJames An2015-12-07 22:03:09 -0500
commit9cf4f1dcf4c18c16341560b51be2c413898e98b5 (patch)
treeea4d1586177d920832e60f2ae449f0ee499e1a87
downloadaur-9cf4f1dcf4c18c16341560b51be2c413898e98b5.tar.gz
Initial commit with working PKGBUILD.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore23
-rw-r--r--PKGBUILD20
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2b61710c56f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Dec 8 03:01:29 UTC 2015
+pkgbase = solr5-zip
+ pkgdesc = Popular, blazing fast open source enterprise search platform from the Apache Lucene project
+ pkgver = 5.3.1
+ pkgrel = 1
+ url = http://lucene.apache.org/solr
+ arch = any
+ license = Apache
+ depends = java-environment>=7
+ provides = solr=5
+ provides = solr5=5
+ conflicts = solr
+ noextract = http://www.apache.org/dist/lucene/solr/5.3.1/solr-5.3.1.zip
+ source = http://www.apache.org/dist/lucene/solr/5.3.1/solr-5.3.1.zip
+ md5sums = c69eb24acb3821408eacf00651cc7022
+
+pkgname = solr5-zip
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1b24130fb180
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,23 @@
+# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# makepkg working folders
+pkg
+src
+
+# Source files
+*.deb
+*.gem
+*.out
+*.rpm
+*.html
+
+# Ignore package source folders
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eec75e954fe5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: James An <james@jamesan.ca>
+
+_pkgname=solr
+pkgname="${_pkgname}5-zip"
+pkgver=5.3.1
+pkgrel=1
+pkgdesc='Popular, blazing fast open source enterprise search platform from the Apache Lucene project'
+arch=('any')
+url="http://lucene.apache.org/$_pkgname"
+license=('Apache')
+depends=('java-environment>=7')
+provides=("$_pkgname=5" "${_pkgname}5=5")
+conflicts=("$_pkgname")
+source=("http://www.apache.org/dist/lucene/$_pkgname/$pkgver/$_pkgname-$pkgver.zip")
+md5sums=('c69eb24acb3821408eacf00651cc7022')
+noextract=("${source[@]%%::*}")
+
+package() {
+ install -Dm644 "$_pkgname-$pkgver.zip" "$pkgdir/usr/share/java/lib/$_pkgname/$_pkgname-$pkgver.zip"
+}