summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Egorov2023-07-12 22:01:52 +0300
committerAlexander Egorov2023-07-12 22:01:52 +0300
commit691fd6208b94c9385807698300482f82a4de8d7a (patch)
tree72f769bd2d49721d140d12be63a5b958bd7ea3e4
downloadaur-691fd6208b94c9385807698300482f82a4de8d7a.tar.gz
solv 0.8.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87f609b25a7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = solv
+ pkgdesc = SOLution Validation tool that analyzes Microsoft Visual Studio solutions
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://github.com/aegoroff/solv
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = cargo
+
+pkgname = solv
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..111e87d21973
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: egoroff <egoroff@gmail.com>
+pkgname=solv
+pkgver=0.8.0
+pkgrel=1
+makedepends=('cargo')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+pkgdesc="SOLution Validation tool that analyzes Microsoft Visual Studio solutions"
+url="https://github.com/aegoroff/solv"
+license=('MIT')
+
+build() {
+ return 0
+}
+
+package() {
+ cargo install --no-track --root "$pkgdir/usr/" solv
+}