summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Egorov2023-09-10 14:07:40 +0300
committerAlexander Egorov2023-09-10 14:07:40 +0300
commit579bdbbe04cc73a71acc063810eec471f8b7b158 (patch)
tree7ee24940a9745e862d88e4e04ba7e916f65892ca
parentebbfdf1ebf11b7d8d4866a0976811bae6637f249 (diff)
downloadaur-579bdbbe04cc73a71acc063810eec471f8b7b158.tar.gz
solv 0.13.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b563cf78fcae..2954be0b990e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = solv-bin
pkgdesc = SOLution Validation tool that analyzes Microsoft Visual Studio solutions (binary release)
- pkgver = 0.12.1
+ pkgver = 0.13.0
pkgrel = 1
url = https://github.com/aegoroff/solv
arch = x86_64
license = MIT
- source = https://github.com/aegoroff/solv/releases/download/0.12.1/solv-0.12.1-x86_64-unknown-linux-musl.tar.gz
- sha256sums = 1c0b467fbc7ca6b1458a7a1e41ba13f4a6b133cab3384b7808d7c7a8e1baa2d0
+ source = https://github.com/aegoroff/solv/releases/download/0.13.0/solv-0.13.0-x86_64-unknown-linux-musl.tar.gz
+ sha256sums = 84d89f631abdbf8987ba6ca28eb0ab574d3371e07385c00cb345e133f87935cc
pkgname = solv-bin
+ provides = solv-bin
+ conflicts = solv-bin
+ conflicts = solv
diff --git a/PKGBUILD b/PKGBUILD
index 6c966dc0a101..80e3b4ed5707 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,22 @@
# Maintainer: egoroff <egoroff@gmail.com>
pkgname=solv-bin
-pkgver=0.12.1
+pkgver=0.13.0
pkgrel=1
arch=('x86_64')
pkgdesc="SOLution Validation tool that analyzes Microsoft Visual Studio solutions (binary release)"
url="https://github.com/aegoroff/solv"
license=('MIT')
source=("https://github.com/aegoroff/solv/releases/download/${pkgver}/solv-${pkgver}-x86_64-unknown-linux-musl.tar.gz")
-sha256sums=('1c0b467fbc7ca6b1458a7a1e41ba13f4a6b133cab3384b7808d7c7a8e1baa2d0')
+sha256sums=('84d89f631abdbf8987ba6ca28eb0ab574d3371e07385c00cb345e133f87935cc')
build() {
return 0
}
package() {
+ provides=("solv-bin")
+ conflicts=("solv-bin" "solv")
+
install -Dm0755 "solv" "$pkgdir/usr/bin/solv"
+ install -Dm0555 "LICENSE.txt" "$pkgdir/usr/share/licenses/solv/LICENSE.txt"
}