summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2024-03-26 21:51:05 +0100
committerbegin-theadventure2024-03-26 21:51:05 +0100
commit996403b7f11296a9f8e6e41a88874f361ddd0d42 (patch)
treee1d3f8082b165d4b6d6742134b6f645baa5e91fe
parentfe99b2cd946929a0b6004b69bde3ad81e2890403 (diff)
downloadaur-996403b7f11296a9f8e6e41a88874f361ddd0d42.tar.gz
1.2.9, SPDX license, use commit, package
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f4b6f4fbc63..584f364d47e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = somafm
pkgdesc = A simple radio with built-in stations from the website somafm.com
- pkgver = 1.2.8
+ pkgver = 1.2.9
pkgrel = 1
url = https://github.com/alexkdeveloper/somafm
arch = x86_64
arch = aarch64
- license = GPL3
+ license = GPL-3.0-or-later
checkdepends = appstream-glib
makedepends = git
makedepends = meson
@@ -13,7 +13,7 @@ pkgbase = somafm
depends = gstreamer
depends = libadwaita
depends = libpulse
- source = git+https://github.com/alexkdeveloper/somafm.git#tag=1.2.8
+ source = git+https://github.com/alexkdeveloper/somafm.git#commit=44bc0ca641cf0e668b43c7648771c11ea3ad1098
sha256sums = SKIP
pkgname = somafm
diff --git a/PKGBUILD b/PKGBUILD
index c4edad3a1aa9..9237190bc642 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
pkgname=somafm
-pkgver=1.2.8
+pkgver=1.2.9
pkgrel=1
pkgdesc='A simple radio with built-in stations from the website somafm.com'
url="https://github.com/alexkdeveloper/somafm"
+license=('GPL-3.0-or-later')
arch=('x86_64' 'aarch64')
-license=('GPL3')
depends=('gstreamer' 'libadwaita' 'libpulse')
makedepends=('git' 'meson' 'vala')
checkdepends=('appstream-glib')
-source=("git+$url.git#tag=$pkgver")
+_commit=44bc0ca641cf0e668b43c7648771c11ea3ad1098
+source=("git+$url.git#commit=$_commit")
sha256sums=('SKIP')
build() {
@@ -23,6 +24,6 @@ check() {
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
ln -s com.github.alexkdeveloper.somafm "$pkgdir/usr/bin/somafm"
}