summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2014-06-08 08:43:46 +0400
committerAnton Leontiev2015-02-15 07:48:22 +0300
commit56c3c2f118fb485993c905cd32d60b00b1ce20eb (patch)
tree13bed524efcfca2fce49585644830bd63eed0720
downloadaur-56c3c2f118fb485993c905cd32d60b00b1ce20eb.tar.gz
Initial v2.3.1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD27
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc00b4db4125
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sombok
+ pkgdesc = Line breaking (line folding) library respecting Unicode
+ pkgver = 2.3.1
+ pkgrel = 1
+ url = https://sourceforge.net/projects/linefold/
+ arch = i686
+ arch = x86_64
+ license = PerlArtistic
+ license = GPL2
+ depends = libthai
+ source = http://downloads.sourceforge.net/project/linefold/sombok/sombok-2.3.1.tar.gz
+ md5sums = c22465f4e08ed2b5dd3e144a6a607a5c
+
+pkgname = sombok
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eaf39af910a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Anton Leontiev <bunder /at/ t-25.ru>
+pkgname=sombok
+pkgver=2.3.1
+pkgrel=1
+pkgdesc='Line breaking (line folding) library respecting Unicode'
+arch=('i686' 'x86_64')
+url='https://sourceforge.net/projects/linefold/'
+license=('PerlArtistic' 'GPL2')
+source=(http://downloads.sourceforge.net/project/linefold/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('c22465f4e08ed2b5dd3e144a6a607a5c')
+depends=('libthai')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --enable-libthai --disable-doc
+ make
+}
+
+check() {
+ cd $pkgname-$pkgver
+ make check
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make -j1 DESTDIR="$pkgdir" install
+}