summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordNhax2018-01-31 17:44:58 +0100
committerdNhax2018-01-31 17:44:58 +0100
commit1ff4504cb380cc32e56f0ca9ef7618f0a61be3da (patch)
tree0423d83379db4d4b5dc87cdfbd5b694175772c8c
parentbcd83fbf842ed04faa22116a0a5af646b05648b7 (diff)
downloadaur-1ff4504cb380cc32e56f0ca9ef7618f0a61be3da.tar.gz
Updated to version 6.7.1, smaller cleanups
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD31
-rw-r--r--sonarqube.service4
3 files changed, 20 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 721a90762fb5..0ff613c20203 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,9 @@
-# Generated by mksrcinfo v8
-# Sun Jan 22 00:29:57 UTC 2017
pkgbase = sonarqube-lts
pkgdesc = An open source platform for continuous inspection of code quality
- pkgver = 5.6.4
+ pkgver = 6.7.1
pkgrel = 1
url = http://www.sonarqube.org/
install = sonarqube-lts.install
- arch = i686
arch = x86_64
license = LGPL3
depends = java-runtime>=8
@@ -19,12 +16,12 @@ pkgbase = sonarqube-lts
options = !strip
backup = etc/sonarqube/sonar.properties
backup = etc/sonarqube/wrapper.conf
- source = https://sonarsource.bintray.com/Distribution/sonarqube/sonarqube-5.6.4.zip
+ source = https://sonarsource.bintray.com/Distribution/sonarqube/sonarqube-6.7.1.zip
source = sonarqube.service
source = sonarqube-tmpfile.conf
source = sonarqube-user.conf
- sha256sums = 3a4916b82d04843941a427058dae951578450e235a14f95811535bf9f30bf33b
- sha256sums = acf98543b635778a690c5d1a8796bf67de725eeda1c72856bd63ea148a892223
+ sha256sums = 74cc70ef75d83fa260c7be86863416f45e092f77a2582ab51529d84f9a696fc7
+ sha256sums = cb3e3e810892e4d7ccf7a843ae1cb7daa14e3395025d0cc505b562f45e4f1ee9
sha256sums = 6e024de469ebb1bc4083274412f0a5d68d5fa511c2139ce4cb1d243c51ff9535
sha256sums = 43ff10bbb495827e952225dce79da79bb800627eaa6f1d933f8f7fb408aafe6d
diff --git a/PKGBUILD b/PKGBUILD
index af621bcd5edb..2d5c0c1ea821 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
-# Submitter: Peter Lamby <peterlamby@web.de>
-# Maintainer: Max Falk <gmdfalk@gmail.com>
+# Maintainer: Tobias Hübner <dasNeutrum at gmx dot de>
_pkgname=sonarqube
pkgname=${_pkgname}-lts
-pkgver=5.6.4
+pkgver=6.7.1
pkgrel=1
pkgdesc="An open source platform for continuous inspection of code quality"
-arch=("i686" "x86_64")
+arch=("x86_64")
url="http://www.sonarqube.org/"
license=('LGPL3')
@@ -30,17 +29,23 @@ source=("https://sonarsource.bintray.com/Distribution/${_pkgname}/${_pkgname}-${
"${_pkgname}-tmpfile.conf"
"${_pkgname}-user.conf")
-sha256sums=('3a4916b82d04843941a427058dae951578450e235a14f95811535bf9f30bf33b'
- 'acf98543b635778a690c5d1a8796bf67de725eeda1c72856bd63ea148a892223'
+sha256sums=('74cc70ef75d83fa260c7be86863416f45e092f77a2582ab51529d84f9a696fc7'
+ 'cb3e3e810892e4d7ccf7a843ae1cb7daa14e3395025d0cc505b562f45e4f1ee9'
'6e024de469ebb1bc4083274412f0a5d68d5fa511c2139ce4cb1d243c51ff9535'
'43ff10bbb495827e952225dce79da79bb800627eaa6f1d933f8f7fb408aafe6d')
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- # Copy everything except bin and conf to /usr/share/sonarqube.
+ # Copy everything except conf and logs to /usr/share/sonarqube.
install -dm755 "${pkgdir}/usr/share/${_pkgname}"
- cp -dr --no-preserve=ownership {bin,data,extensions,lib,temp,web} "${pkgdir}/usr/share/${_pkgname}/"
+ cp -dr --no-preserve=ownership {bin,data,elasticsearch,extensions,lib,temp,web} "${pkgdir}/usr/share/${_pkgname}/"
+
+ # Delete unused files.
+ rm -rf "${pkgdir}/usr/share/${_pkgname}/bin/linux-x86-32"
+ rm -rf "${pkgdir}/usr/share/${_pkgname}/bin/macosx-universal-64"
+ rm -rf "${pkgdir}/usr/share/${_pkgname}/bin/windows-x86-32"
+ rm -rf "${pkgdir}/usr/share/${_pkgname}/bin/windows-x86-64"
# Install the license.
install -Dm644 "COPYING" "${pkgdir}/usr/share/doc/${_pkgname}/COPYING"
@@ -55,18 +60,10 @@ package() {
install -Dm644 "${_pkgname}-user.conf" "${pkgdir}/usr/lib/sysusers.d/${_pkgname}.conf"
install -Dm644 "${_pkgname}-tmpfile.conf" "${pkgdir}/usr/lib/tmpfiles.d/${_pkgname}.conf"
- # Symbolic links because SonarQube expects a specific directory layout.
+ # Create symbolic links because SonarQube expects a specific directory layout.
ln -s "/var/log/${_pkgname}" "${pkgdir}/usr/share/${_pkgname}/logs"
ln -s "/run/${_pkgname}" "${pkgdir}/usr/share/${_pkgname}/run"
ln -s "/etc/${_pkgname}" "${pkgdir}/usr/share/${_pkgname}/conf"
-
- # Modify the service file in place to adjust the binary path to the CPU architecture. This is necessary because
- # SonarQube expects a certain directory layout. The alternative would be to patch SonarQube's config files.
- if [[ "$CARCH" == 'x86_64' ]]; then
- sed -i 's/\$ARCH/linux-x86-64/g' "${pkgdir}/usr/lib/systemd/system/${_pkgname}.service"
- elif [[ "$CARCH" == 'i686' ]]; then
- sed -i 's/\$ARCH/linux-x86-32/g' "${pkgdir}/usr/lib/systemd/system/${_pkgname}.service"
- fi
}
diff --git a/sonarqube.service b/sonarqube.service
index 556ceaf6ef6b..0b6f2dc50895 100644
--- a/sonarqube.service
+++ b/sonarqube.service
@@ -12,8 +12,8 @@ StandardOutput=syslog
StandardError=syslog
SyslogIdentifier=sonarqube
RuntimeDirectory=sonarqube
-ExecStart=/usr/share/sonarqube/bin/$ARCH/sonar.sh start
-ExecStop=/usr/share/sonarqube/bin/$ARCH/sonar.sh stop
+ExecStart=/usr/share/sonarqube/bin/linux-x86-64/sonar.sh start
+ExecStop=/usr/share/sonarqube/bin/linux-x86-64/sonar.sh stop
[Install]
WantedBy=multi-user.target