summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLars2016-10-15 14:25:30 +0200
committerLars2016-10-15 14:25:30 +0200
commit3244278dba8d2118330e68c0ed660be3cb341075 (patch)
tree56f33631a215d3562c08c34cbbe8fc746eaca5be
parent1fdc5048e79bc4202e85245272e34061e4b583d8 (diff)
downloadaur-3244278dba8d2118330e68c0ed660be3cb341075.tar.gz
Use patches instead of PRs
-rwxr-xr-xPKGBUILD25
1 files changed, 7 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f5419451467..61ad8f1bc62b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,8 @@ _gitname="Sonarr"
_gitver="2.0.0"
_gitbranch="develop"
-# NB: Only for pull requests in origin
-_git_patches=""
-_git_patches+="783:mono-process-name "
-
pkgname="sonarr-git"
-pkgver=2.0.0.r6807.2299860
+pkgver=2.0.0.r6923.713e109
pkgrel=1
pkgdesc="Automated TV series manager and downloader - git branch ${_gitbranch}"
arch=(any)
@@ -31,10 +27,12 @@ install='sonarr.install'
changelog=
source=("git://github.com/Sonarr/Sonarr.git#branch=${_gitbranch}"
"sonarr.sh"
- "sonarr.service")
+ "sonarr.service"
+ "0001-Mono-Set-process-name.patch")
sha256sums=('SKIP'
'd594c4d5ad3c1b196a00cb9f005d4917ad4d8bb2ebf501010e8be7f349b3caa6'
- '1ebf903e6199dae6032c7839b00ed20566404daf87cb307ffc9ee8539722a845')
+ '1ebf903e6199dae6032c7839b00ed20566404daf87cb307ffc9ee8539722a845'
+ '28ed9a1aa71d0d255c18e2ca17c52b845f69c19e3d2653607cff9a7f478931e1')
pkgver() {
@@ -49,17 +47,8 @@ prepare() {
# Install necessary nodejs libraries
npm install
- # Git complains if user is not already set
- [[ `git config user.email` ]] || git config user.email "you@example.com"
- [[ `git config user.name` ]] || git config user.name "Your Name"
-
- for patch in ${_git_patches}; do
- id=`echo ${patch} | cut -d \: -f 1`
- name=`echo ${patch} | cut -d \: -f 2`
- msg2 "Patching ${name} from (https://github.com/Sonarr/Sonarr/pull/${id}"
- git fetch origin pull/${id}/head:${name} --force
- git rebase ${name} --force-rebase --ignore-whitespace --quiet
- done
+ msg2 "Patching Mono-Set-process-name"
+ git apply --ignore-whitespace "${srcdir}/0001-Mono-Set-process-name.patch"
git submodule update --init
}