summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJelle van der Waa2019-12-23 15:01:48 +0100
committerJelle van der Waa2019-12-23 15:01:48 +0100
commit2ffa6aeef5126fab7e1d9a14ef46ec9cac148652 (patch)
tree90c9eff2828ac64c33abd24c847c88e9e62e298f
downloadaur-2ffa6aeef5126fab7e1d9a14ef46ec9cac148652.tar.gz
move to AUR
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
-rw-r--r--info.py.patch15
-rw-r--r--mpd-0.18.patch25
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5529d8d000b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = sonata
+ pkgdesc = Elegant GTK+ music client for MPD
+ pkgver = 1.6.2.1
+ pkgrel = 14
+ url = https://sourceforge.net/projects/sonata.berlios
+ arch = x86_64
+ license = GPL3
+ depends = pygtk
+ depends = python2-mpd
+ optdepends = python2-tagpy: Metadata editing support
+ optdepends = python2-dbus: Various extra functionality (e.g. multimedia keys support)
+ provides = python2-mmkeys
+ source = https://downloads.sourceforge.net/sourceforge/sonata.berlios/sonata-1.6.2.1.tar.gz
+ source = mpd-0.18.patch
+ source = info.py.patch
+ md5sums = 0b912325e7175abad3bf6c0edc071e05
+ md5sums = 9bc61f5015f415dc16ceb84a95c99f5e
+ md5sums = 595fcf7615035829b264afecb5a1beeb
+
+pkgname = sonata
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65d5718bc918
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+# Contributor: William Rea <sillywilly@gmail.com>
+
+pkgname=sonata
+pkgver=1.6.2.1
+pkgrel=14
+pkgdesc="Elegant GTK+ music client for MPD"
+arch=('x86_64')
+url="https://sourceforge.net/projects/sonata.berlios"
+license=('GPL3')
+depends=('pygtk' 'python2-mpd')
+optdepends=('python2-tagpy: Metadata editing support'
+ 'python2-dbus: Various extra functionality (e.g. multimedia keys support)')
+provides=('python2-mmkeys')
+source=("https://downloads.sourceforge.net/sourceforge/${pkgname}.berlios/${pkgname}-$pkgver.tar.gz"
+ mpd-0.18.patch
+ info.py.patch)
+md5sums=('0b912325e7175abad3bf6c0edc071e05'
+ '9bc61f5015f415dc16ceb84a95c99f5e'
+ '595fcf7615035829b264afecb5a1beeb')
+
+build() {
+ cd ${pkgname}-$pkgver
+ patch -Np1 -i "$srcdir/mpd-0.18.patch"
+ patch -Np0 -i "$srcdir/info.py.patch"
+ sed -i 's|/usr/bin/env python|/usr/bin/env python2|' sonata/breadcrumbs.py
+}
+
+package() {
+ cd ${pkgname}-$pkgver
+ python2 setup.py install --prefix=/usr --optimize=1 --root="$pkgdir"
+}
diff --git a/info.py.patch b/info.py.patch
new file mode 100644
index 000000000000..e95cc3a081fc
--- /dev/null
+++ b/info.py.patch
@@ -0,0 +1,15 @@
+--- sonata/info.py 2011-07-05 22:32:08.452556016 -0500
++++ sonata/info.py 2011-07-05 22:45:50.849311466 -0500
+@@ -393,9 +393,9 @@
+ if content.startswith("#REDIRECT [["):
+ addr = "http://lyricwiki.org/index.php?title=%s&action=edit" % urllib.quote(content.split("[[")[1].split("]]")[0])
+ content = urllib.urlopen(addr).read()
+- lyrics = content.split("&lt;lyrics&gt;")[1].split("&lt;/lyrics&gt;")[0]
+- if lyrics.strip() != "&lt;!-- PUT LYRICS HERE (and delete this entire line) --&gt;":
+- lyrics = misc.unescape_html(lyrics)
++ content = misc.unescape_html(content)
++ lyrics = content.split("<lyrics>")[1].split("</lyrics>")[0].strip()
++ if lyrics.strip() != "<!-- PUT LYRICS HERE (and delete this entire line) -->":
+ lyrics = misc.wiki_to_html(lyrics)
+ lyrics = lyrics.decode("utf-8")
+ # Save lyrics to file:
diff --git a/mpd-0.18.patch b/mpd-0.18.patch
new file mode 100644
index 000000000000..681fb1665ce5
--- /dev/null
+++ b/mpd-0.18.patch
@@ -0,0 +1,25 @@
+diff -aur sonata-1.6.2.1/sonata/main.py sonata-1.6.2.1.new/sonata/main.py
+--- sonata-1.6.2.1/sonata/main.py 2009-09-22 01:02:16.000000000 +0400
++++ sonata-1.6.2.1.new/sonata/main.py 2013-11-01 15:59:08.919054767 +0400
+@@ -989,13 +989,14 @@
+ self.repeatmenu.set_active(self.status['repeat'] == '1')
+ if not self.last_random or self.last_random != self.status['random']:
+ self.randommenu.set_active(self.status['random'] == '1')
+- if self.status['xfade'] == '0':
+- self.config.xfade_enabled = False
+- else:
+- self.config.xfade_enabled = True
+- self.config.xfade = int(self.status['xfade'])
+- if self.config.xfade > 30:
+- self.config.xfade = 30
++ #if self.status['xfade'] == '0':
++ # self.config.xfade_enabled = False
++ #else:
++ # self.config.xfade_enabled = True
++ # self.config.xfade = int(self.status['xfade'])
++ # if self.config.xfade > 30:
++ # self.config.xfade = 30
++ self.config.xfade_enabled = False
+ self.last_repeat = self.status['repeat']
+ self.last_random = self.status['random']
+ return