summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2015-09-18 08:53:05 +0000
committerJonas Heinrich2015-09-18 08:53:05 +0000
commit76549bf95f3d0e732728a671a93a78f5432d0c9b (patch)
treee02f3b481f9d47ae59c9982bc5496ce2ab39fd8c
downloadaur-76549bf95f3d0e732728a671a93a78f5432d0c9b.tar.gz
first commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
-rw-r--r--sonerezh.install0
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5ca70e3fe2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = sonerezh-git
+ pkgdesc = A self-hosted, web-based application for stream your music, everywhere
+ pkgver = 6.0.2.r3.gd57e367
+ pkgrel = 1
+ url = https://www.sonerezh.bzh
+ install = sonerezh.install
+ arch = any
+ license = GPL3
+ depends = php
+ depends = php-gd
+ optdepends = mariadb: Database backend
+ options = !strip
+ source = git+https://github.com/Sonerezh/sonerezh.git
+ source = sonerezh.install
+ sha512sums = SKIP
+ sha512sums = cf83e1357eefb8bdf1542850d66d8007d620e4050b5715dc83f4a921d36ce9ce47d0d13c5d85f2b0ff8318d2877eec2f63b931bd47417a81a538327af927da3e
+
+pkgname = sonerezh-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e4b3255d99b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=sonerezh-git
+_pkgname=sonerezh
+pkgver=6.0.2.r3.gd57e367
+pkgrel=1
+pkgdesc='A self-hosted, web-based application for stream your music, everywhere'
+arch=('any')
+url='https://www.sonerezh.bzh'
+license=('GPL3')
+depends=('php' 'php-gd')
+optdepends=('mariadb: Database backend')
+options=('!strip')
+install="${_pkgname}.install"
+
+source=("git+https://github.com/Sonerezh/sonerezh.git"
+ "${_pkgname}.install")
+
+sha512sums=('SKIP'
+ 'cf83e1357eefb8bdf1542850d66d8007d620e4050b5715dc83f4a921d36ce9ce47d0d13c5d85f2b0ff8318d2877eec2f63b931bd47417a81a538327af927da3e')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ install -d "${pkgdir}/usr/share/webapps/sonerezh"
+ cp -r * "${pkgdir}/usr/share/webapps/sonerezh/"
+
+ install -d "${pkgdir}/etc/webapps/sonerezh"
+
+ install -d "${pkgdir}/usr/share/doc/sonerezh"
+ #install -Dm644 "${srcdir}/example_nginx_vhost.conf" "${pkgdir}/usr/share/doc/pydio/"
+}
diff --git a/sonerezh.install b/sonerezh.install
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sonerezh.install