summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathias Buhr2022-01-22 11:27:41 +0100
committerMathias Buhr2022-01-22 11:27:41 +0100
commit0bfcacfe41a1eb51f7c43b6ce7038fbd497701c7 (patch)
treee6e10cf2abcd4c5dcc4ded1e875658ff3e24f622
parent02fd1e1886c07ac036ee2c298a11d61214c4c767 (diff)
downloadaur-0bfcacfe41a1eb51f7c43b6ce7038fbd497701c7.tar.gz
Fix clean build issue
-rw-r--r--.SRCINFO2
-rw-r--r--FullDTW.h.patch11
-rw-r--r--PKGBUILD3
3 files changed, 14 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9f79a5f0e29..8edf69a6e64c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sonic-lineup
pkgdesc = Sonic Lineup is a free, open-source application for Windows, Linux, and Mac, designed for rapid visualisation of multiple audio files containing versions of the same source material
pkgver = 1.1
- pkgrel = 3
+ pkgrel = 4
url = https://www.sonicvisualiser.org/sonic-lineup/
arch = x86_64
license = GPL2
diff --git a/FullDTW.h.patch b/FullDTW.h.patch
new file mode 100644
index 000000000000..9d087fb09452
--- /dev/null
+++ b/FullDTW.h.patch
@@ -0,0 +1,11 @@
+--- src/sonic-lineup-1.1/match/src/FullDTW.h 2022-01-22 11:15:25.298078377 +0100
++++ src/sonic-lineup-1.1/match/src/FullDTW.h.patched 2022-01-22 11:15:15.491541875 +0100
+@@ -83,7 +83,7 @@
+ * against the best-matching subsequence of s1; otherwise it is
+ * against the whole of s1.
+ */
+- std::vector<size_t> align(const featureseq_t &s1,
++ std::vector<std::size_t> align(const featureseq_t &s1,
+ const featureseq_t &s2);
+
+ private:
diff --git a/PKGBUILD b/PKGBUILD
index 83ded33db44e..807789ecec15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
DLAGENTS=("https::/usr/bin/curl -k -o %o %u")
pkgname=sonic-lineup
pkgver=1.1
-pkgrel=3
+pkgrel=4
pkgdesc="Sonic Lineup is a free, open-source application for Windows, Linux, and Mac, designed for rapid visualisation of multiple audio files containing versions of the same source material"
arch=('x86_64')
url="https://www.sonicvisualiser.org/sonic-lineup/"
@@ -43,6 +43,7 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
export INSTALL_ROOT="${pkgdir}/"
./configure --prefix=/usr
+ patch match/src/FullDTW.h ../../FullDTW.h.patch
make
}