summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathias Buhr2020-01-02 14:34:13 +0100
committerMathias Buhr2020-01-02 14:34:13 +0100
commit38e4c6861e311a6e7384a9649b88eb116ff10f41 (patch)
tree162598fe61708c017a550697c084136685380bc5
parent0cdcbb212a39a50dd48298afe7aa96853afb722f (diff)
downloadaur-38e4c6861e311a6e7384a9649b88eb116ff10f41.tar.gz
Update to 1.0.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
-rw-r--r--sonic-lineup-1.0.1.patch11
3 files changed, 21 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81e51afd3c5c..69328641a11c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sonic-lineup
pkgdesc = Sonic Lineup is a free, open-source application for Windows, Linux, and Mac, designed for rapid visualisation of multiple audio files containing versions of the same source material
- pkgver = 1.0
+ pkgver = 1.0.1
pkgrel = 2
url = https://www.sonicvisualiser.org/sonic-lineup/
arch = x86_64
@@ -22,6 +22,7 @@ pkgbase = sonic-lineup
depends = libsndfile
depends = libx11
depends = opus
+ depends = opusfile
depends = portaudio
depends = qt5-base
depends = qt5-base
@@ -29,8 +30,8 @@ pkgbase = sonic-lineup
depends = rubberband
depends = serd
depends = sord
- source = sonic-lineup-1.0.tar.gz::https://code.soundsoftware.ac.uk/attachments/download/2581/sonic-lineup-1.0.tar.gz
- sha1sums = ac37f1b0cfcd25c6b9e1f9c7e42a5c64da1b3677
+ source = sonic-lineup-1.0.1.tar.gz::https://code.soundsoftware.ac.uk/attachments/download/2610/sonic-lineup-1.0.1.tar.gz
+ sha1sums = 426bdc3a6e9f702659f0338b6e471c013d74128a
pkgname = sonic-lineup
diff --git a/PKGBUILD b/PKGBUILD
index 026603ab8272..737b7c3d8bd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Mathias Buhr <napcode@apparatus..de>
+# Maintainer: Mathias Buhr <napcode@apparatus.de>
pkgname=sonic-lineup
-pkgver=1.0
+pkgver=1.0.1
pkgrel=2
pkgdesc="Sonic Lineup is a free, open-source application for Windows, Linux, and Mac, designed for rapid visualisation of multiple audio files containing versions of the same source material"
arch=('x86_64')
@@ -22,6 +22,7 @@ depends=(
'libsndfile'
'libx11'
'opus'
+ 'opusfile'
'portaudio'
'qt5-base'
'qt5-base'
@@ -35,13 +36,14 @@ makedepends=(
'make'
'boost'
)
-source=("${pkgname}-${pkgver}.tar.gz::https://code.soundsoftware.ac.uk/attachments/download/2581/${pkgname}-${pkgver}.tar.gz")
-sha1sums=('ac37f1b0cfcd25c6b9e1f9c7e42a5c64da1b3677')
+source=("${pkgname}-${pkgver}.tar.gz::https://code.soundsoftware.ac.uk/attachments/download/2610/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('426bdc3a6e9f702659f0338b6e471c013d74128a')
build() {
cd "$srcdir/$pkgname-$pkgver"
export INSTALL_ROOT="${pkgdir}/"
./configure --prefix=/usr
+ patch -Np1 -i "../../${pkgname}-${pkgver}.patch"
make
}
diff --git a/sonic-lineup-1.0.1.patch b/sonic-lineup-1.0.1.patch
new file mode 100644
index 000000000000..99a439e616c9
--- /dev/null
+++ b/sonic-lineup-1.0.1.patch
@@ -0,0 +1,11 @@
+diff --git a/checker/checker.pri b/checker/checker.pri
+--- a/checker/checker.pri
++++ b/checker/checker.pri
+@@ -3,7 +3,6 @@
+ QT -= xml network gui widgets
+
+ !win32 {
+- QMAKE_CXXFLAGS += -Werror
+ }
+
+ OBJECTS_DIR = o