summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathias Buhr2020-03-14 19:40:12 +0100
committerMathias Buhr2020-03-14 19:40:12 +0100
commitc70aad4ea80d22abed3f28446aa6820485c51153 (patch)
tree3a73d085c8d7e7629db448218b0fdb5233b86d01
parent38e4c6861e311a6e7384a9649b88eb116ff10f41 (diff)
downloadaur-c70aad4ea80d22abed3f28446aa6820485c51153.tar.gz
Fix package dependencies
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69328641a11c..7f6f77ea4f1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = sonic-lineup
pkgdesc = Sonic Lineup is a free, open-source application for Windows, Linux, and Mac, designed for rapid visualisation of multiple audio files containing versions of the same source material
pkgver = 1.0.1
- pkgrel = 2
+ pkgrel = 3
url = https://www.sonicvisualiser.org/sonic-lineup/
arch = x86_64
license = GPL2
- makedepends = gcc
- makedepends = make
makedepends = boost
+ depends = capnproto
depends = boost-libs
depends = fftw
depends = jack2
@@ -25,13 +24,13 @@ pkgbase = sonic-lineup
depends = opusfile
depends = portaudio
depends = qt5-base
- depends = qt5-base
+ depends = qt5-svg
depends = qt5-tools
depends = rubberband
depends = serd
depends = sord
source = sonic-lineup-1.0.1.tar.gz::https://code.soundsoftware.ac.uk/attachments/download/2610/sonic-lineup-1.0.1.tar.gz
- sha1sums = 426bdc3a6e9f702659f0338b6e471c013d74128a
+ sha256sums = 278675925e2a4242bd6dd3c1fdf80474e51ce4061908e44f820eb580f22f9b70
pkgname = sonic-lineup
diff --git a/PKGBUILD b/PKGBUILD
index 737b7c3d8bd0..4fa49c53978d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
pkgname=sonic-lineup
pkgver=1.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Sonic Lineup is a free, open-source application for Windows, Linux, and Mac, designed for rapid visualisation of multiple audio files containing versions of the same source material"
arch=('x86_64')
url="https://www.sonicvisualiser.org/sonic-lineup/"
license=('GPL2')
depends=(
+ 'capnproto'
'boost-libs'
'fftw'
'jack2'
@@ -25,19 +26,17 @@ depends=(
'opusfile'
'portaudio'
'qt5-base'
- 'qt5-base'
+ 'qt5-svg'
'qt5-tools'
'rubberband'
'serd'
'sord'
)
makedepends=(
- 'gcc'
- 'make'
'boost'
)
source=("${pkgname}-${pkgver}.tar.gz::https://code.soundsoftware.ac.uk/attachments/download/2610/${pkgname}-${pkgver}.tar.gz")
-sha1sums=('426bdc3a6e9f702659f0338b6e471c013d74128a')
+sha256sums=('278675925e2a4242bd6dd3c1fdf80474e51ce4061908e44f820eb580f22f9b70')
build() {
cd "$srcdir/$pkgname-$pkgver"