summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Melo2021-01-21 21:20:32 -0300
committerLucas Melo2021-01-21 21:20:32 -0300
commit06188351f8264ca8c0d2330ec3f28d8c6a0bf7ec (patch)
treebfda117a80e4db6d7a11b3d1cb9451dc0293f218
parentaf639fe98c626cd00dafdb69c6e1756e04f949ee (diff)
downloadaur-06188351f8264ca8c0d2330ec3f28d8c6a0bf7ec.tar.gz
Updated pkgbuild, launcher script and .install.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rwxr-xr-xsoniccd-launcher22
-rw-r--r--soniccd.install7
4 files changed, 23 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc83fca56ba7..4f0b93edbebb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = soniccd-git
pkgdesc = A full decompilation of Sonic CD 2011, based on the PC remake with improvements & tweaks from the mobile remakes.
- pkgver = r143.e0b421d
- pkgrel = 1
+ pkgver = r153.ce80f35
+ pkgrel = 2
url = https://github.com/Rubberduckycooly/Sonic-CD-11-Decompilation
install = soniccd.install
arch = any
- license = reverse-engineered and unlicensed
+ license = unknown
makedepends = git
depends = sdl2
depends = libogg
@@ -16,7 +16,7 @@ pkgbase = soniccd-git
source = soniccd-launcher
source = soniccd.desktop
sha256sums = SKIP
- sha256sums = 55621606d74d3fa04d7ae0046ac88623648c587dae2b6addd1e081a587f6fe6d
+ sha256sums = 83b086300728ae627907ac042ded29ff5d00077261ebcdf3c5c93da6b1350a0e
sha256sums = 5ef3e25f5391707fdc461a8c25817ddde38a1d34d125dc5b3c43f706b889ed8a
pkgname = soniccd-git
diff --git a/PKGBUILD b/PKGBUILD
index c2e906a98735..10e574bf5500 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Lucas Melo <luluco250 at gmail dot com>
pkgname=soniccd-git
-pkgver=r143.e0b421d
-pkgrel=1
+pkgver=r153.ce80f35
+pkgrel=2
pkgdesc='A full decompilation of Sonic CD 2011, based on the PC remake with
improvements & tweaks from the mobile remakes.'
arch=('any')
url='https://github.com/Rubberduckycooly/Sonic-CD-11-Decompilation'
-license=('reverse-engineered and unlicensed')
+license=('unknown')
makedepends=('git')
depends=('sdl2' 'libogg' 'libtheora' 'libvorbis')
provides=(soniccd)
@@ -17,7 +17,7 @@ source=(
'soniccd.desktop')
sha256sums=(
'SKIP'
- '55621606d74d3fa04d7ae0046ac88623648c587dae2b6addd1e081a587f6fe6d'
+ '83b086300728ae627907ac042ded29ff5d00077261ebcdf3c5c93da6b1350a0e'
'5ef3e25f5391707fdc461a8c25817ddde38a1d34d125dc5b3c43f706b889ed8a')
install=soniccd.install
diff --git a/soniccd-launcher b/soniccd-launcher
index 1f41fc85e9fd..211b709f38cc 100755
--- a/soniccd-launcher
+++ b/soniccd-launcher
@@ -11,16 +11,16 @@ if [[ ! -d "$data_folder" ]]; then
exit 1
fi
-# Check if the user forgot to copy data files, if not exit with error code 1.
-#
-# If we don't do this check, the game will still create the settings and save
-# files, but not run (nor set an error code), which can be confusing to the
-# end user.
-if [[ -z "$(ls -A $data_folder)" ]]; then
- echo "Data folder appears to be empty, please copy the game's data files" \
-"and run this launcher again."
- exit 1
-fi
-
cd "$data_folder"
/usr/bin/soniccd
+
+exit_code=$?
+
+# When implemented, exit code 1 will indicate missing data.
+# Let's hope that doesn't change, right? :D
+if [[ $exit_code -eq 1 ]]; then
+ echo "'/usr/bin/soniccd' exited with error code 1, did you forget to" \
+"copy the game's data files to '$data_folder'?"
+fi
+
+exit $exit_code
diff --git a/soniccd.install b/soniccd.install
index 0789c2159a62..d1e06b706c02 100644
--- a/soniccd.install
+++ b/soniccd.install
@@ -1,5 +1,6 @@
post_install() {
- echo 'Use soniccd-launcher to create the data folder inside your home '\
-"folder, copy the game's data files to it and then run it again to launch the "\
-'game.'
+ echo "Use 'soniccd-launcher' to automatically run 'soniccd' from a " \
+"'soniccd' folder in your \$XDG_DATA_HOME or '~/.local/share' folder."
+ echo "Alternatively, you may simply run 'soniccd' directly from any " \
+"folder containing compatible data files."
}