summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Melo2021-09-07 11:31:15 -0300
committerLucas Melo2021-09-07 11:31:15 -0300
commit9fcfaeccbb4556ac59f2489d75c33220a1761ed5 (patch)
treea11d9178ce160e77fc92ab9ce1f5993dfc9bad46
parent268d50d37205877eed1204fadd49600b9916cebe (diff)
downloadaur-9fcfaeccbb4556ac59f2489d75c33220a1761ed5.tar.gz
Bumped pkgver and added tinyxml2 build dependency.
Linux builds are still broken in upstream, maybe they'll be fixed by the next release, but it's not considered a priority by the developer.
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
3 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42b455168b4e..73be40123cd1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = soniccd-git
pkgdesc = A full decompilation of Sonic CD 2011, based on the PC remake with improvements & tweaks from the mobile remakes.
- pkgver = r263.4edf2f9
+ pkgver = r330.1a1ad84
pkgrel = 1
url = https://github.com/Rubberduckycooly/Sonic-CD-11-Decompilation
install = soniccd.install
@@ -13,11 +13,12 @@ pkgbase = soniccd-git
depends = libvorbis
provides = soniccd
source = git+https://github.com/Rubberduckycooly/Sonic-CD-11-Decompilation.git
+ source = git+https://github.com/leethomason/tinyxml2.git
source = soniccd-launcher
source = soniccd.desktop
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 83b086300728ae627907ac042ded29ff5d00077261ebcdf3c5c93da6b1350a0e
sha256sums = 5ef3e25f5391707fdc461a8c25817ddde38a1d34d125dc5b3c43f706b889ed8a
pkgname = soniccd-git
-
diff --git a/.gitignore b/.gitignore
index b5e38c5129ce..462369da0b03 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
/pkg/
/src/
/Sonic-CD-11-Decompilation/
+/tinyxml2/
/*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index ea99b53152b0..f0a98eeb2bda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lucas Melo <luluco250 at gmail dot com>
pkgname=soniccd-git
-pkgver=r263.4edf2f9
+pkgver=r330.1a1ad84
pkgrel=1
pkgdesc='A full decompilation of Sonic CD 2011, based on the PC remake with
improvements & tweaks from the mobile remakes.'
@@ -13,12 +13,16 @@ depends=('sdl2' 'libogg' 'libtheora' 'libvorbis')
provides=(soniccd)
source=(
"git+${url}.git"
+ 'git+https://github.com/leethomason/tinyxml2.git'
'soniccd-launcher'
- 'soniccd.desktop')
+ 'soniccd.desktop'
+)
sha256sums=(
'SKIP'
+ 'SKIP'
'83b086300728ae627907ac042ded29ff5d00077261ebcdf3c5c93da6b1350a0e'
- '5ef3e25f5391707fdc461a8c25817ddde38a1d34d125dc5b3c43f706b889ed8a')
+ '5ef3e25f5391707fdc461a8c25817ddde38a1d34d125dc5b3c43f706b889ed8a'
+)
install=soniccd.install
pkgver() {
@@ -26,9 +30,13 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ ln -sfn "$srcdir/tinyxml2" "$srcdir/Sonic-CD-11-Decompilation/dependencies/all/tinyxml2"
+}
+
build() {
cd "$srcdir/Sonic-CD-11-Decompilation"
- make ${MAKEFLAGS:--j$(nproc)}
+ make ${MAKEFLAGS:--j$(nproc)} # CXXFLAGS=O2
}
package() {