summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Melo2022-02-28 12:50:54 -0300
committerLucas Melo2022-02-28 12:50:54 -0300
commitbd5d2c0615aec4b0f08ab8a7f7b8f0f3f0d2940a (patch)
tree845d56e74e5e5cd8a042f5ee1f753ac87c1e5fdc
parentf206d87b98a296ad9b41f0c587b71eadf389b16c (diff)
downloadaur-bd5d2c0615aec4b0f08ab8a7f7b8f0f3f0d2940a.tar.gz
Upstream changed tinyxml2 to a submodule.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7210967c6d2b..da42a5ebc3aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = soniccd-git
pkgdesc = A full decompilation of Sonic CD 2011, based on the PC remake with improvements & tweaks from the mobile remakes.
- pkgver = r423.f0d510c
+ pkgver = r476.972e89f
pkgrel = 1
url = https://github.com/Rubberduckycooly/Sonic-CD-11-Decompilation
install = soniccd.install
@@ -14,9 +14,11 @@ pkgbase = soniccd-git
depends = tinyxml2
provides = soniccd
source = git+https://github.com/Rubberduckycooly/Sonic-CD-11-Decompilation.git
+ source = git+https://github.com/leethomason/tinyxml2.git
source = soniccd-launcher
source = soniccd.desktop
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = b70b6526c137859385234a19d1935e089c3c6a71639f42f7d579135579e8243b
sha256sums = 5ef3e25f5391707fdc461a8c25817ddde38a1d34d125dc5b3c43f706b889ed8a
diff --git a/PKGBUILD b/PKGBUILD
index 6769d3aab7b8..90fd67405901 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lucas Melo <luluco250 at gmail dot com>
pkgname=soniccd-git
-pkgver=r423.f0d510c
+pkgver=r476.972e89f
pkgrel=1
pkgdesc='A full decompilation of Sonic CD 2011, based on the PC remake with
improvements & tweaks from the mobile remakes.'
@@ -9,15 +9,17 @@ arch=('any')
url='https://github.com/Rubberduckycooly/Sonic-CD-11-Decompilation'
license=('custom:RSDKv3/4 Decompilation Source Code License v1')
makedepends=('git')
-depends=('sdl2' 'libogg' 'libtheora' 'libvorbis' 'tinyxml2')
+depends=('sdl2' 'libogg' 'libtheora' 'libvorbis')
provides=(soniccd)
source=(
"git+${url}.git"
+ 'git+https://github.com/leethomason/tinyxml2.git'
'soniccd-launcher'
'soniccd.desktop'
)
sha256sums=(
'SKIP'
+ 'SKIP'
'b70b6526c137859385234a19d1935e089c3c6a71639f42f7d579135579e8243b'
'5ef3e25f5391707fdc461a8c25817ddde38a1d34d125dc5b3c43f706b889ed8a'
)
@@ -28,6 +30,13 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/Sonic-CD-11-Decompilation"
+ git submodule init
+ git submodule set-url -- dependencies/all/tinyxml2 "$srcdir/tinyxml2"
+ git submodule update dependencies/all/tinyxml2
+}
+
build() {
cd "$srcdir/Sonic-CD-11-Decompilation"
make ${MAKEFLAGS:--j$(nproc)} # CXXFLAGS=O2