summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Melo2021-10-20 14:31:57 -0300
committerLucas Melo2021-10-20 14:31:57 -0300
commite065e7b067f3b1a25e754f8ee68f21a219d25932 (patch)
tree7535d399f6c2d00c893c7cffd92c1435fe911f85
parentc34fbe67856cabc2b56038b1b85d11e407346ac9 (diff)
downloadaur-e065e7b067f3b1a25e754f8ee68f21a219d25932.tar.gz
Updated soniccd package.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rwxr-xr-xsoniccd-launcher2
-rw-r--r--soniccd.install11
4 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73be40123cd1..90bcc2c02e01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = soniccd-git
pkgdesc = A full decompilation of Sonic CD 2011, based on the PC remake with improvements & tweaks from the mobile remakes.
- pkgver = r330.1a1ad84
+ pkgver = r377.907d631
pkgrel = 1
url = https://github.com/Rubberduckycooly/Sonic-CD-11-Decompilation
install = soniccd.install
@@ -18,7 +18,7 @@ pkgbase = soniccd-git
source = soniccd.desktop
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 83b086300728ae627907ac042ded29ff5d00077261ebcdf3c5c93da6b1350a0e
+ sha256sums = b70b6526c137859385234a19d1935e089c3c6a71639f42f7d579135579e8243b
sha256sums = 5ef3e25f5391707fdc461a8c25817ddde38a1d34d125dc5b3c43f706b889ed8a
pkgname = soniccd-git
diff --git a/PKGBUILD b/PKGBUILD
index f0a98eeb2bda..e7b2f0593f05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lucas Melo <luluco250 at gmail dot com>
pkgname=soniccd-git
-pkgver=r330.1a1ad84
+pkgver=r377.907d631
pkgrel=1
pkgdesc='A full decompilation of Sonic CD 2011, based on the PC remake with
improvements & tweaks from the mobile remakes.'
@@ -20,7 +20,7 @@ source=(
sha256sums=(
'SKIP'
'SKIP'
- '83b086300728ae627907ac042ded29ff5d00077261ebcdf3c5c93da6b1350a0e'
+ 'b70b6526c137859385234a19d1935e089c3c6a71639f42f7d579135579e8243b'
'5ef3e25f5391707fdc461a8c25817ddde38a1d34d125dc5b3c43f706b889ed8a'
)
install=soniccd.install
@@ -43,6 +43,6 @@ package() {
install -Dm755 soniccd-launcher "$pkgdir/usr/bin/soniccd-launcher"
install -Dm644 soniccd.desktop "$pkgdir/usr/share/applications/soniccd.desktop"
cd "$srcdir/Sonic-CD-11-Decompilation/bin"
- install -Dm755 soniccd "$pkgdir/usr/bin/soniccd"
+ install -Dm755 RSDKv3 "$pkgdir/usr/bin/RSDKv3"
install -Dm644 ../LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/soniccd-launcher b/soniccd-launcher
index 211b709f38cc..fb401e859db6 100755
--- a/soniccd-launcher
+++ b/soniccd-launcher
@@ -12,7 +12,7 @@ if [[ ! -d "$data_folder" ]]; then
fi
cd "$data_folder"
-/usr/bin/soniccd
+/usr/bin/RSDKv3
exit_code=$?
diff --git a/soniccd.install b/soniccd.install
index d1e06b706c02..7888a1025c4f 100644
--- a/soniccd.install
+++ b/soniccd.install
@@ -4,3 +4,14 @@ post_install() {
echo "Alternatively, you may simply run 'soniccd' directly from any " \
"folder containing compatible data files."
}
+
+post_upgrade() {
+ old_revision=$(egrep -o '[0-9]+' <<< $2 | head -n 1)
+
+ # Not sure what was the exact commit that changed the binary name, but it
+ # doesn't really matter.
+ if [[ $old_revision < 377 ]]; then
+ echo '"soniccd" has been renamed to "RSDKv3", "soniccd-launcher" '\
+'remains unaffected'
+ fi
+}