summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Melo2021-12-15 07:58:39 -0300
committerLucas Melo2021-12-15 07:58:39 -0300
commitf206d87b98a296ad9b41f0c587b71eadf389b16c (patch)
tree457ca2f85048b8a24e47d96fc27a6720368bd888
parente065e7b067f3b1a25e754f8ee68f21a219d25932 (diff)
downloadaur-f206d87b98a296ad9b41f0c587b71eadf389b16c.tar.gz
Converted tinyxml2 to a standard package dependency.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 4 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90bcc2c02e01..7210967c6d2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = soniccd-git
pkgdesc = A full decompilation of Sonic CD 2011, based on the PC remake with improvements & tweaks from the mobile remakes.
- pkgver = r377.907d631
+ pkgver = r423.f0d510c
pkgrel = 1
url = https://github.com/Rubberduckycooly/Sonic-CD-11-Decompilation
install = soniccd.install
@@ -11,13 +11,12 @@ pkgbase = soniccd-git
depends = libogg
depends = libtheora
depends = libvorbis
+ depends = tinyxml2
provides = soniccd
source = git+https://github.com/Rubberduckycooly/Sonic-CD-11-Decompilation.git
- source = git+https://github.com/leethomason/tinyxml2.git
source = soniccd-launcher
source = soniccd.desktop
sha256sums = SKIP
- sha256sums = SKIP
sha256sums = b70b6526c137859385234a19d1935e089c3c6a71639f42f7d579135579e8243b
sha256sums = 5ef3e25f5391707fdc461a8c25817ddde38a1d34d125dc5b3c43f706b889ed8a
diff --git a/PKGBUILD b/PKGBUILD
index e7b2f0593f05..6769d3aab7b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lucas Melo <luluco250 at gmail dot com>
pkgname=soniccd-git
-pkgver=r377.907d631
+pkgver=r423.f0d510c
pkgrel=1
pkgdesc='A full decompilation of Sonic CD 2011, based on the PC remake with
improvements & tweaks from the mobile remakes.'
@@ -9,17 +9,15 @@ arch=('any')
url='https://github.com/Rubberduckycooly/Sonic-CD-11-Decompilation'
license=('custom:RSDKv3/4 Decompilation Source Code License v1')
makedepends=('git')
-depends=('sdl2' 'libogg' 'libtheora' 'libvorbis')
+depends=('sdl2' 'libogg' 'libtheora' 'libvorbis' 'tinyxml2')
provides=(soniccd)
source=(
"git+${url}.git"
- 'git+https://github.com/leethomason/tinyxml2.git'
'soniccd-launcher'
'soniccd.desktop'
)
sha256sums=(
'SKIP'
- 'SKIP'
'b70b6526c137859385234a19d1935e089c3c6a71639f42f7d579135579e8243b'
'5ef3e25f5391707fdc461a8c25817ddde38a1d34d125dc5b3c43f706b889ed8a'
)
@@ -30,10 +28,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- ln -sfn "$srcdir/tinyxml2" "$srcdir/Sonic-CD-11-Decompilation/dependencies/all/tinyxml2"
-}
-
build() {
cd "$srcdir/Sonic-CD-11-Decompilation"
make ${MAKEFLAGS:--j$(nproc)} # CXXFLAGS=O2