summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun2023-12-09 18:44:52 +0800
committeryjun2023-12-09 18:44:52 +0800
commit79b91dc818a2f91c657bc4a29402334b62b6899e (patch)
treed6fb5ca1e4b35041ef01732383085a7c0c1d8404
downloadaur-79b91dc818a2f91c657bc4a29402334b62b6899e.tar.gz
[init]: sonix-flasher-c-git 1.1.0.r9.g548174b
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD32
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36660fdb8950
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sonix-flasher-c-git
+ pkgdesc = A CLI-based Flasher for Sonix 24x/26x MCUs.
+ pkgver = 1.1.0.r9.g548174b
+ pkgrel = 1
+ url = https://github.com/SonixQMK/SonixFlasherC
+ arch = x86_64
+ arch = aarch64
+ license = GPL-3.0-only
+ depends = glibc
+ depends = hidapi
+ depends = libudev.s0=1
+ source = git+https://github.com/SonixQMK/SonixFlasherC
+ sha256sums = SKIP
+
+pkgname = sonix-flasher-c-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cc14e03c675e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.zst
+sonix-flasher/
+pkg/
+src/
+SonixFlasherC
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83e485469ec6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: yjun <jerrysteve1101 at gmail dot com>
+
+pkgname=sonix-flasher-c-git
+_gitname=SonixFlasherC
+pkgver=1.1.0.r9.g548174b
+pkgrel=1
+pkgdesc="A CLI-based Flasher for Sonix 24x/26x MCUs."
+arch=('x86_64' 'aarch64')
+url="https://github.com/SonixQMK/SonixFlasherC"
+license=('GPL-3.0')
+depends=('glibc'
+ 'hidapi'
+ 'libudev.so=1')
+source=("git+https://github.com/SonixQMK/SonixFlasherC")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${_gitname}"
+ make sonixflasher
+}
+
+package() {
+ cd "${_gitname}"
+
+ install -Dm755 sonixflasher -t "$pkgdir/usr/bin"
+}
+# vim: ts=2 sw=2 et: