summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorj.r2022-01-18 00:19:29 +0100
committerj.r2022-01-18 00:19:29 +0100
commit995d19950b9826b5f69ed9725c3a4e41e237fb3c (patch)
tree261c43acf934f246145e8e9f6b60d17f3e36ecd7
parent0ac8aa66382080e2861032d2e55c4bade174425c (diff)
downloadaur-995d19950b9826b5f69ed9725c3a4e41e237fb3c.tar.gz
sonixd: add desktop entry
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD8
-rw-r--r--sonixd.desktop7
4 files changed, 16 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb9b0e10db90..a3f0756c44b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,7 +14,9 @@ pkgbase = sonixd
replaces = sonixd-appimage
source = sonixd-0.11.0.tar.gz::https://github.com/jeffvli/sonixd/archive/refs/tags/v0.11.0.tar.gz
source = sonixd
+ source = sonixd.desktop
sha256sums = 7a6f05612d2459d07d49d885d7547fd62d44745f53b4073f1da4e7bdab36fb13
sha256sums = 89039f59dc58490cc5a2e05bb38b3645448df56b2e763d6170facb64e73241d0
+ sha256sums = 9e2e1cce47b594b75b8df7a1cf3a5a6da340dda9d0cfdf2aa305d097fc0bbc7a
pkgname = sonixd
diff --git a/.gitignore b/.gitignore
index 16ed3d6e6c34..50ee41fec863 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,3 +6,4 @@
!*.patch
!*.diff
!sonixd
+!*.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 84395e377698..2f3d57a5a42f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,9 +11,11 @@ makedepends=('yarn' 'nvm' 'asar')
conflicts=("$pkgname-appimage")
replaces=("$pkgname-appimage")
source=("$pkgname-$pkgver.tar.gz::https://github.com/jeffvli/sonixd/archive/refs/tags/v$pkgver.tar.gz"
- "$pkgname")
+ "$pkgname"
+ "$pkgname.desktop")
sha256sums=('7a6f05612d2459d07d49d885d7547fd62d44745f53b4073f1da4e7bdab36fb13'
- '89039f59dc58490cc5a2e05bb38b3645448df56b2e763d6170facb64e73241d0')
+ '89039f59dc58490cc5a2e05bb38b3645448df56b2e763d6170facb64e73241d0'
+ '9e2e1cce47b594b75b8df7a1cf3a5a6da340dda9d0cfdf2aa305d097fc0bbc7a')
_ensure_local_nvm() {
which nvm >/dev/null 2>&1 && nvm deactivate && nvm unload
@@ -47,12 +49,14 @@ build() {
package() {
install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
cd "$pkgname-$pkgver"
local i686=linux-ia32-unpacked x86_64=linux-unpacked
install -d "$pkgdir/usr/lib/$pkgname/"
+ install -Dm644 "release/${!CARCH}/resources/assets/icons/512x512.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
cp -r "release/${!CARCH}/resources/assets" "$pkgdir/usr/lib/$pkgname"
asar e "release/${!CARCH}/resources/app.asar" "$pkgdir/usr/lib/$pkgname/$pkgname/"
}
diff --git a/sonixd.desktop b/sonixd.desktop
new file mode 100644
index 000000000000..840548ffded1
--- /dev/null
+++ b/sonixd.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Sonixd
+Exec=sonixd
+Terminal=false
+Type=Application
+Icon=sonixd
+Categories=Audio;AudioVideo