summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Lisin2022-03-19 00:37:34 +0100
committerMatthias Lisin2022-03-19 00:37:34 +0100
commitb3e12addf9a056ac3b8b467f861f1aff2cb7bc51 (patch)
tree923dafaf4603b5a2ddbfcdbf55b85adbdf7286e1
parent4b9d79e221e13c7cd5ec19432b88d3f4c09a588a (diff)
downloadaur-b3e12addf9a056ac3b8b467f861f1aff2cb7bc51.tar.gz
updpkg: sonobuoy 0.56.3-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4673b8cf0262..195af0d0ea50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sonobuoy
pkgdesc = Diagnostic tool for Kubernetes clusters
- pkgver = 0.56.2
+ pkgver = 0.56.3
pkgrel = 1
url = https://github.com/vmware-tanzu/sonobuoy
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = sonobuoy
depends = glibc
optdepends = docker: sonobuoy images subcommand
optdepends = kubectl: advances workflows
- source = https://github.com/vmware-tanzu/sonobuoy/archive/v0.56.2/sonobuoy-0.56.2.tar.gz
- sha256sums = e435fbd3a29447fa69ac9ff151159a385e08f4b2e63f33e20e73b8d22071f440
+ source = https://github.com/vmware-tanzu/sonobuoy/archive/v0.56.3/sonobuoy-0.56.3.tar.gz
+ sha256sums = 26a3bf677a7013a3ce6da080b2c983c72cfe7d5fe9e1d4964df0e6f0abb30419
pkgname = sonobuoy
diff --git a/PKGBUILD b/PKGBUILD
index 2165f116a595..5aa96ed320ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: ml <>
pkgname=sonobuoy
-pkgver=0.56.2
+pkgver=0.56.3
pkgrel=1
pkgdesc='Diagnostic tool for Kubernetes clusters'
arch=('x86_64')
@@ -12,7 +12,7 @@ optdepends=(
'kubectl: advances workflows')
makedepends=('go' 'git')
source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('e435fbd3a29447fa69ac9ff151159a385e08f4b2e63f33e20e73b8d22071f440')
+sha256sums=('26a3bf677a7013a3ce6da080b2c983c72cfe7d5fe9e1d4964df0e6f0abb30419')
build() {
local _commit _defines
@@ -31,11 +31,6 @@ build() {
go build -o "$pkgname" -ldflags "-linkmode=external ${_defines[*]/#/-X=}" main.go
}
-check() {
- cd "$pkgname-$pkgver"
- GODEBUG=x509ignoreCN=0 go test -ldflags=-linkmode=external ./cmd/... ./pkg/...
-}
-
package() {
cd "$pkgname-$pkgver"
install -Dm755 "$pkgname" -t "$pkgdir/usr/bin"