summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2022-06-18 23:04:39 +0200
committerSefa Eyeoglu2022-06-18 23:04:39 +0200
commit982873310a8f2ab964847b0f6809a7d2d940541b (patch)
tree13c7ea89554071f9f03dee660658f7ceb7c572df
parentb11a442820accbd7f4a0ecf2e3d9de8894f4a118 (diff)
downloadaur-982873310a8f2ab964847b0f6809a7d2d940541b.tar.gz
upgpkg: sonobus 1.5.1-2
Fix build
-rw-r--r--.SRCINFO6
-rw-r--r--.gitattributes1
-rw-r--r--0001-fix-add-missing-include.patch24
-rw-r--r--PKGBUILD14
4 files changed, 40 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36415e01bba6..012aa444f197 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sonobus
pkgdesc = An easy to use application for streaming high-quality, low-latency peer-to-peer audio
pkgver = 1.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://sonobus.net
arch = i686
arch = x86_64
@@ -15,7 +15,9 @@ pkgbase = sonobus
depends = libxcursor
depends = libasound.so=2-64
depends = libjack.so=0-64
- source = sonobus-1.5.1::https://github.com/sonosaurus/sonobus/archive/refs/tags/1.5.1.tar.gz
+ source = sonobus-1.5.1.tar.gz::https://github.com/sonosaurus/sonobus/archive/refs/tags/1.5.1.tar.gz
+ source = 0001-fix-add-missing-include.patch
sha512sums = 329ef7c4b3bfe391673c5af871a2fdf688514f443550303ee7d83c3e25864fd4782ce1fe36f9fdf67d82a9964f566cb095b94d1165b66a7b705c558d2661a47a
+ sha512sums = 735821f1be3e602a222f8c45d6561f02dd127be526875e6783e243d1a2ad8269103ec7199810fd1d1d08eefd8c5c769f035ef339e8aca4b2ac9b4feff6c6f416
pkgname = sonobus
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000000..ec1ffa81eddd
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1 @@
+*.patch -text
diff --git a/0001-fix-add-missing-include.patch b/0001-fix-add-missing-include.patch
new file mode 100644
index 000000000000..e0f661a38491
--- /dev/null
+++ b/0001-fix-add-missing-include.patch
@@ -0,0 +1,24 @@
+From 1bd6881f1409e9e88ed0bf4de411f7d34bbaf43e Mon Sep 17 00:00:00 2001
+From: Sefa Eyeoglu <contact@scrumplex.net>
+Date: Sat, 18 Jun 2022 22:45:08 +0200
+Subject: [PATCH] fix: add missing include to juce_linux_Windowing
+
+---
+ .../juce/modules/juce_gui_basics/native/juce_linux_Windowing.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/deps/juce/modules/juce_gui_basics/native/juce_linux_Windowing.cpp b/deps/juce/modules/juce_gui_basics/native/juce_linux_Windowing.cpp
+index 64897716..38258c68 100644
+--- a/deps/juce/modules/juce_gui_basics/native/juce_linux_Windowing.cpp
++++ b/deps/juce/modules/juce_gui_basics/native/juce_linux_Windowing.cpp
+@@ -22,6 +22,7 @@
+
+ ==============================================================================
+ */
++#include <utility>
+
+ namespace juce
+ {
+--
+2.36.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 1ca5a22fbae7..955b4bc7607f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,23 @@
pkgname=sonobus
pkgver=1.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="An easy to use application for streaming high-quality, low-latency peer-to-peer audio"
arch=('i686' 'x86_64' 'aarch64')
url="https://sonobus.net"
license=('GPL3')
depends=('opus' 'freetype2' 'libxrandr' 'libxinerama' 'libxcursor' 'libasound.so=2-64' 'libjack.so=0-64')
makedepends=('cmake')
-source=("sonobus-$pkgver::https://github.com/sonosaurus/sonobus/archive/refs/tags/${pkgver}.tar.gz")
-sha512sums=('329ef7c4b3bfe391673c5af871a2fdf688514f443550303ee7d83c3e25864fd4782ce1fe36f9fdf67d82a9964f566cb095b94d1165b66a7b705c558d2661a47a')
+source=("sonobus-$pkgver.tar.gz::https://github.com/sonosaurus/sonobus/archive/refs/tags/${pkgver}.tar.gz"
+ "0001-fix-add-missing-include.patch")
+sha512sums=('329ef7c4b3bfe391673c5af871a2fdf688514f443550303ee7d83c3e25864fd4782ce1fe36f9fdf67d82a9964f566cb095b94d1165b66a7b705c558d2661a47a'
+ '735821f1be3e602a222f8c45d6561f02dd127be526875e6783e243d1a2ad8269103ec7199810fd1d1d08eefd8c5c769f035ef339e8aca4b2ac9b4feff6c6f416')
+
+prepare() {
+ cd "sonobus-${pkgver}"
+
+ patch -Np1 -i ../0001-fix-add-missing-include.patch
+}
build() {
cd "sonobus-${pkgver}"