summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Werling2021-01-20 22:43:03 +0100
committerLukas Werling2021-01-20 22:43:03 +0100
commitd443c5883a4557918b17754a7223a16c779e8e96 (patch)
tree4cb160720de245ec9a7dd49de70584e9cc7c9d2a
downloadaur-d443c5883a4557918b17754a7223a16c779e8e96.tar.gz
sonobuild 1.3.2
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD22
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf6c9b39fb51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Wed Jan 20 21:42:33 UTC 2021
+pkgbase = sonobus
+ pkgdesc = An easy to use application for streaming high-quality, low-latency peer-to-peer audio
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = https://sonobus.net
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = opus
+ depends = curl
+ depends = freetype2
+ depends = libxrandr
+ depends = libxinerama
+ depends = libxcursor
+ depends = libgl
+ depends = libasound.so=2-64
+ depends = libjack.so=0-64
+ source = https://github.com/essej/sonobus/archive/1.3.2.tar.gz
+ sha256sums = 298e073d2369530a130efe17292dec2ab3990bfd0b72b1532c8f9fedea623435
+
+pkgname = sonobus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ced16282d8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Lukas Werling <lukas@lwrl.de>
+pkgname=sonobus
+pkgver=1.3.2
+pkgrel=1
+pkgdesc="An easy to use application for streaming high-quality, low-latency peer-to-peer audio"
+arch=('i686' 'x86_64')
+url="https://sonobus.net"
+license=('GPL3')
+depends=('opus' 'curl' 'freetype2' 'libxrandr' 'libxinerama' 'libxcursor' 'libgl' 'libasound.so=2-64' 'libjack.so=0-64')
+makedepends=()
+source=("https://github.com/essej/sonobus/archive/${pkgver}.tar.gz")
+sha256sums=('298e073d2369530a130efe17292dec2ab3990bfd0b72b1532c8f9fedea623435')
+
+build() {
+ cd "sonobus-${pkgver}/Builds/LinuxMakefile"
+ ./build.sh
+}
+
+package() {
+ cd "sonobus-${pkgver}/Builds/LinuxMakefile"
+ ./install.sh "$pkgdir/usr"
+}