summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik Schwaiger2022-03-28 17:26:24 +0200
committerDominik Schwaiger2022-03-28 17:26:24 +0200
commit2201b267b3bfd580334f980d2ed8088ae42c177e (patch)
tree667fa45bd75984bd7e0183e099e35a87c91d0c2b
parentdc1e9e3b9a3085ee3e27c930890dd44a4fdd730c (diff)
downloadaur-2201b267b3bfd580334f980d2ed8088ae42c177e.tar.gz
license, works
-rw-r--r--.SRCINFO8
-rw-r--r--MIT21
-rw-r--r--PKGBUILD21
-rw-r--r--sonyheadphonesclient-bin.install3
4 files changed, 42 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62fc5e3d464f..e6ab4341e143 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,10 +5,16 @@ pkgbase = sonyheadphonesclient-bin
url = https://github.com/Plutoberth/SonyHeadphonesClient
install = sonyheadphonesclient-bin.install
arch = x86_64
- license = MIT
+ license = custom:MIT
depends = glfw-x11
+ depends = minizip
+ depends = dbus
+ depends = bluez-libs
+ depends = glew
optdepends = glfw-doc
source = https://github.com/Plutoberth/SonyHeadphonesClient/releases/download/v1.2/SonyHeadphonesClient-linux-x64.zip
+ source = MIT
+ md5sums = SKIP
md5sums = SKIP
pkgname = sonyheadphonesclient-bin
diff --git a/MIT b/MIT
new file mode 100644
index 000000000000..afda95451aef
--- /dev/null
+++ b/MIT
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2020 Nir Harel, Mor Gal, Sem Visscher, jimzrt, guilhermealbm, and other contributors
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 51225bcd1044..05e480f4fe92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,9 @@ epoch=
pkgdesc="A {Windows, macOS, Linux} client recreating the functionality of the Sony Headphones app"
arch=("x86_64")
url="https://github.com/Plutoberth/SonyHeadphonesClient"
-license=('MIT')
+license=('custom:MIT')
groups=()
-depends=("glfw-x11")
+depends=("glfw-x11" "minizip" "dbus" "bluez-libs" "glew")
makedepends=()
checkdepends=()
optdepends=("glfw-doc")
@@ -19,9 +19,9 @@ backup=()
options=()
install=sonyheadphonesclient-bin.install
changelog=
-source=("https://github.com/Plutoberth/SonyHeadphonesClient/releases/download/v$pkgver/SonyHeadphonesClient-linux-x64.zip")
+source=("https://github.com/Plutoberth/SonyHeadphonesClient/releases/download/v$pkgver/SonyHeadphonesClient-linux-x64.zip" "MIT")
noextract=()
-md5sums=("SKIP")
+md5sums=("SKIP" "SKIP")
validpgpkeys=()
# prepare() {
@@ -40,20 +40,23 @@ validpgpkeys=()
# }
package() {
- unzip "SonyHeadphonesClient-linux-x64.zip"
+ unzip -o -qq "SonyHeadphonesClient-linux-x64.zip"
rm "SonyHeadphonesClient-linux-x64.zip"
mkdir -p "$pkgdir/usr/bin/"
mv SonyHeadphonesClient "$pkgdir/usr/bin/"
chmod +x "$pkgdir/usr/bin/SonyHeadphonesClient"
# Desktop entry
- mkdir -p "$pkgbuild/home/$USER/.local/share/applications/"
- touch "$pkgbuild/home/$USER/.local/share/applications/SonyHeadphonesClient.desktop"
+ mkdir -p "$pkgdir/usr/share/applications/"
echo "[Desktop Entry]
Name=Sony Headphones Client
Exec=SonyHeadphonesClient
- Terminal=false
+ Terminal=falsey
Type=Application
Icon=application-executable
- Categories=Accessoires;" >>"$pkgbuild/home/$USER/.local/share/applications/SonyHeadphonesClient.desktop"
+ Categories=Accessoires;" >>"$pkgdir/usr/share/applications/SonyHeadphonesClient.desktop"
+
+ # License
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname/"
+ cp MIT "$pkgdir/usr/share/licenses/$pkgname/"
}
diff --git a/sonyheadphonesclient-bin.install b/sonyheadphonesclient-bin.install
index 793e69061106..d9a86c5b4b6a 100644
--- a/sonyheadphonesclient-bin.install
+++ b/sonyheadphonesclient-bin.install
@@ -1,5 +1,6 @@
# arg 1: the old package version
post_remove() {
rm "/usr/bin/SonyHeadphonesClient"
- rm "/home/$USER/.local/share/applications/SonyHeadphonesClient.desktop"
+ rm "/usr/share/applications/SonyHeadphonesClient.desktop"
+ rm -r "/usr/share/licenses/sonyheadphonesclient-bin"
}