summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeon Spengler2018-10-24 07:38:08 +0200
committerDeon Spengler2018-10-24 07:38:08 +0200
commit2f4d31e88a5d5b6dd36dbb514317b0f7328223b9 (patch)
treef128dde2d4c0e86d6a225aaac5d1a21640bbba84
parent5a690bd3107cf04c09c2e5ef22857227e31a0d3c (diff)
downloadaur-2f4d31e88a5d5b6dd36dbb514317b0f7328223b9.tar.gz
Update to SOPE-4.0.4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--sope-bugfix_4566.patch20
3 files changed, 9 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1537ae47e6d..36b12e4d2723 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sope
pkgdesc = application server used by SOGo
- pkgver = 4.0.2
- pkgrel = 2
+ pkgver = 4.0.4
+ pkgrel = 1
url = http://www.sogo.nu/files/downloads/SOGo/Sources/
arch = x86_64
license = GPL
@@ -20,12 +20,10 @@ pkgbase = sope
optdepends = postgresql: run database server for sogo locally
replaces = sope2
options = !strip
- source = http://www.sogo.nu/files/downloads/SOGo/Sources/SOPE-4.0.2.tar.gz
+ source = http://www.sogo.nu/files/downloads/SOGo/Sources/SOPE-4.0.4.tar.gz
source = sope_configure.patch
- source = sope-bugfix_4566.patch
- sha256sums = 19ebeb0854f63003cd1c99e271e9f8b7476a2c7f666027d46a2e12b6abc94738
+ sha256sums = d882b7238ed506d3f694e2f07674e056b4b9a069bad8837a56bf073c9172d2fb
sha256sums = 7ff3387daffd15b5f97146da1fd61aefc9591b7b6a41f1f0e60b572106fdbc9a
- sha256sums = f46e873f4def6aec07d6ac3bf6ee817f4cd9873928623a731ce98da86aaa3108
pkgname = sope
diff --git a/PKGBUILD b/PKGBUILD
index 1b3f9f41b0c9..a960b9f2dbed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Andre Wayand <aur-sope@awayand.sleepmail.com>
pkgname=sope
pkgdesc="application server used by SOGo"
-pkgver=4.0.2
-pkgrel=2
+pkgver=4.0.4
+pkgrel=1
arch=('x86_64')
url="http://www.sogo.nu/files/downloads/SOGo/Sources/"
license=('GPL')
@@ -25,16 +25,13 @@ optdepends=('libxml2: parse XML coniguration files'
'openssl: create SSL secured connectons'
'postgresql: run database server for sogo locally')
source=("http://www.sogo.nu/files/downloads/SOGo/Sources/SOPE-${pkgver}.tar.gz"
- "sope_configure.patch"
- "sope-bugfix_4566.patch")
-sha256sums=('19ebeb0854f63003cd1c99e271e9f8b7476a2c7f666027d46a2e12b6abc94738'
- '7ff3387daffd15b5f97146da1fd61aefc9591b7b6a41f1f0e60b572106fdbc9a'
- 'f46e873f4def6aec07d6ac3bf6ee817f4cd9873928623a731ce98da86aaa3108')
+ "sope_configure.patch")
+sha256sums=('d882b7238ed506d3f694e2f07674e056b4b9a069bad8837a56bf073c9172d2fb'
+ '7ff3387daffd15b5f97146da1fd61aefc9591b7b6a41f1f0e60b572106fdbc9a')
prepare() {
cd "${srcdir}/SOPE"
patch configure ../sope_configure.patch
- patch -Np1 -i ../sope-bugfix_4566.patch
}
build() {
diff --git a/sope-bugfix_4566.patch b/sope-bugfix_4566.patch
deleted file mode 100644
index 7b24e2248b38..000000000000
--- a/sope-bugfix_4566.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -Naurp SOPE-orig/sope-core/NGStreams/NGActiveSSLSocket.m SOPE/sope-core/NGStreams/NGActiveSSLSocket.m
---- SOPE-orig/sope-core/NGStreams/NGActiveSSLSocket.m 2018-10-10 23:02:55.886959720 -0500
-+++ SOPE/sope-core/NGStreams/NGActiveSSLSocket.m 2018-10-10 23:14:00.079065658 -0500
-@@ -216,13 +216,15 @@ static BIO_METHOD streamBIO = {
- if ((self = [super initWithDomain:_domain])) {
- //BIO *bio_err;
- static BOOL didGlobalInit = NO;
--
-+
-+#if (OPENSSL_VERSION >= 0x01010001f)
- if (!didGlobalInit) {
- /* Global system initialization*/
- SSL_library_init();
- SSL_load_error_strings();
- didGlobalInit = YES;
- }
-+#endif /* OPENSSL_VERSION >= 0x01010001f */
-
- /* An error write context */
- //bio_err = BIO_new_fp(stderr, BIO_NOCLOSE);