summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeon Spengler2018-10-11 09:36:36 +0200
committerDeon Spengler2018-10-11 09:36:36 +0200
commit5a690bd3107cf04c09c2e5ef22857227e31a0d3c (patch)
treeb546fd585447eea935401f0b0fefa9b7a03739bd
parent4ca121d7f89307f126b7829da8fa8a20bc4ef161 (diff)
downloadaur-5a690bd3107cf04c09c2e5ef22857227e31a0d3c.tar.gz
bugfix-4566
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--sope-bugfix_4566.patch20
3 files changed, 29 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c655b10477cd..f1537ae47e6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sope
pkgdesc = application server used by SOGo
pkgver = 4.0.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.sogo.nu/files/downloads/SOGo/Sources/
arch = x86_64
license = GPL
@@ -22,8 +22,10 @@ pkgbase = sope
options = !strip
source = http://www.sogo.nu/files/downloads/SOGo/Sources/SOPE-4.0.2.tar.gz
source = sope_configure.patch
+ source = sope-bugfix_4566.patch
sha256sums = 19ebeb0854f63003cd1c99e271e9f8b7476a2c7f666027d46a2e12b6abc94738
sha256sums = 7ff3387daffd15b5f97146da1fd61aefc9591b7b6a41f1f0e60b572106fdbc9a
+ sha256sums = f46e873f4def6aec07d6ac3bf6ee817f4cd9873928623a731ce98da86aaa3108
pkgname = sope
diff --git a/PKGBUILD b/PKGBUILD
index be36e65f5410..1b3f9f41b0c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=sope
pkgdesc="application server used by SOGo"
pkgver=4.0.2
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="http://www.sogo.nu/files/downloads/SOGo/Sources/"
license=('GPL')
@@ -25,13 +25,16 @@ optdepends=('libxml2: parse XML coniguration files'
'openssl: create SSL secured connectons'
'postgresql: run database server for sogo locally')
source=("http://www.sogo.nu/files/downloads/SOGo/Sources/SOPE-${pkgver}.tar.gz"
- "sope_configure.patch")
+ "sope_configure.patch"
+ "sope-bugfix_4566.patch")
sha256sums=('19ebeb0854f63003cd1c99e271e9f8b7476a2c7f666027d46a2e12b6abc94738'
- '7ff3387daffd15b5f97146da1fd61aefc9591b7b6a41f1f0e60b572106fdbc9a')
+ '7ff3387daffd15b5f97146da1fd61aefc9591b7b6a41f1f0e60b572106fdbc9a'
+ 'f46e873f4def6aec07d6ac3bf6ee817f4cd9873928623a731ce98da86aaa3108')
prepare() {
cd "${srcdir}/SOPE"
patch configure ../sope_configure.patch
+ patch -Np1 -i ../sope-bugfix_4566.patch
}
build() {
diff --git a/sope-bugfix_4566.patch b/sope-bugfix_4566.patch
new file mode 100644
index 000000000000..7b24e2248b38
--- /dev/null
+++ b/sope-bugfix_4566.patch
@@ -0,0 +1,20 @@
+diff -Naurp SOPE-orig/sope-core/NGStreams/NGActiveSSLSocket.m SOPE/sope-core/NGStreams/NGActiveSSLSocket.m
+--- SOPE-orig/sope-core/NGStreams/NGActiveSSLSocket.m 2018-10-10 23:02:55.886959720 -0500
++++ SOPE/sope-core/NGStreams/NGActiveSSLSocket.m 2018-10-10 23:14:00.079065658 -0500
+@@ -216,13 +216,15 @@ static BIO_METHOD streamBIO = {
+ if ((self = [super initWithDomain:_domain])) {
+ //BIO *bio_err;
+ static BOOL didGlobalInit = NO;
+-
++
++#if (OPENSSL_VERSION >= 0x01010001f)
+ if (!didGlobalInit) {
+ /* Global system initialization*/
+ SSL_library_init();
+ SSL_load_error_strings();
+ didGlobalInit = YES;
+ }
++#endif /* OPENSSL_VERSION >= 0x01010001f */
+
+ /* An error write context */
+ //bio_err = BIO_new_fp(stderr, BIO_NOCLOSE);